Unable to download packages for patching

When I attempt to run yum update on my RHEL7 servers. I get a failure to pull the kernel-headers package. receive “[Errno 14] HTTPS Error 404 - Not Found” and it points me to the knowledge base article [Errno 14] yum fails with HTTP/HTTPS Error 404 - Red Hat Customer Portal.

Cleaning the yum cache and deleting /var/cache/yum does not fix the problem. I tried rebuilding the subscription manifest and I get another error. “Runtime Error null at org.candlepin.sync.ImporterUtils.populateEntity:66”

I have also tried doing a complete sync on the RHE7 server rpm repo and it fails as well. With “RPM1004: Error retrieving metadata: Forbidden”

Expected outcome:
The server should be able to download packages.

Foreman and Proxy versions:
foreman 1.19.1
katello 3.8.1

Foreman and Proxy plugin versions:

Distribution and version:
Red hat 7.9

Other relevant data:
I understand I am running old versions of this software, but he replacement is currently being built. Hopefully, this will be my last patch day on this foreman server. I appreciate any help offered.

Is there a way I could bypass the foreman/katello server and pull updates straight from redhat?