Unable to find provisioning template

Trying to get foreman to pxe boot a machine but I’m running into the issue where it cannot find the provisioning template. This is seen at the url foreman.example.com/unattended/provision&token=____. I dont understand why this file cannot be found as isnt it the provisioning template that is generating this message? I’ve checked the forum and havent found similar cases. Yes templates are configured accordingly within OS and installation media and host.

Hello @foreman_help what a nice name.

  1. Check the token for typing errors, it must be literally the same
  2. Check the token duration in Administer - Settings. Every token lasts only few hours (by default, you can change that).
  3. Check if you haven’t disabled tokens in the same settings (setting it to zero).
  4. When host cannot be found by token, Foreman tries to find the host by REMOTE IP address. In that case connect to Foreman from a host that is matching the provisioning interface IPv4.

Hi, token is identical and lasts for 360 minutes. It does find the host with the message unable to find provisioning template for host name running host os. Running out of ideas as to why this isnt working.

Look at the unattended_controller in our codebase, it’s pretty straightforward (well in a sense). Doublecheck you haven’t disabled tokens.

By the way you have a wrong URL it must be provision?token=XYZ and not provision&token=XYZ.

Just took a look. Tokens are not disabled, URL mistake was a typo. Still havent figured this one out.

Do you have provision template associated with the host that has the token you are entering?

Pastebin the whole terminal interaction without any changes. You must do something wrong.

Yes, under the host->templates I see PXELinux template which is what I associated the Installation Media/OS with. This is a rebuild on the same machine, could that cause an error? What do you mean by terminal interaction? I installed foreman according to the quickstart and setup the firewall. From then I just used the web interface to create and import my vm as a managed host.

Not PXELinux but provision template. In your URL you ask for provision type of template, which is usually preseed or kickstart.

If you want to download PXELinux template then your url should be /unattended/PXELinux?token=XYZ.

Ah, I have kickstart default PXElinux for my template.

That’s not enough for provisioning.


1 Like

I came across that link in the IRC chat but I’ll take a thorough look again. Odd thing is in my previous build, the current configurations worked fine for PXE booting. Organization/locations are not required right?

Not sure what you mean, but this is now mandatory starting from Foreman I think version 1.20.

Ah okay. Just configured my own Org/Location outside of Default and am still getting the “Unable to find provision template for FQDN running CentOS 7” at the unattended provision link.

Seeing this same behavior on Foreman 2.3.3. It worked just fine on the previous version. Currently trying to figure out what’s going on.

Double check your taxonomy.