Unable to login to SUSE SCC account

I have install katello 3.12.3/foreman 1.22.1 with tfm-rubygem-foreman_scc_manager-1.6.2-1.fm1_22.el7.noarch and I can’t login to SUSE account. When I run “Test Connection” I get Connection test failed!

/var/log/foreman/production.log :

2019-09-09T21:25:52 [I|app|fb9dbc11] Started GET “/notification_recipients” for at 2019-09-09 21:25:52 +0200
2019-09-09T21:25:52 [I|app|fb9dbc11] Processing by NotificationRecipientsController#index as JSON
2019-09-09T21:25:52 [I|app|fb9dbc11] Current user set to admin (admin)
2019-09-09T21:25:52 [I|app|fb9dbc11] Completed 200 OK in 9ms (Views: 0.2ms | ActiveRecord: 1.3ms)
2019-09-09T21:25:52 [I|app|4a2a46ce] Started PUT “/scc_accounts/test_connection?scc_account_id=3” for at 2019-09-09 21:25:52 +0200
2019-09-09T21:25:52 [I|app|4a2a46ce] Processing by SccAccountsController#test_connection as JSON
2019-09-09T21:25:52 [I|app|4a2a46ce] Parameters: {“utf8”=>“✓”, “authenticity_token”=>“iecg82VFgADILK9SwjHVXqC1uLa8m0pKEVm7F0mrAK4crarybm15OgjbHA7t9wPOLjgQxlVmy3MWUfm5v9m13g==”, “scc_account”=>{“name”=>“snt”, “login”=>“XXXX”, “password”=>"[FILTERED]", “base_url”=>“https://scc.suse.com”, “interval”=>“never”, “sync_date”=>“2019-09-09T21:25:06”, “organization_id”=>“3”}, “fakepassword”=>"[FILTERED]", “scc_account_id”=>“3”}
2019-09-09T21:25:52 [I|app|4a2a46ce] Current user set to admin (admin)
2019-09-09T21:25:53 [I|app|4a2a46ce] Completed 404 Not Found in 975ms (Views: 0.2ms | ActiveRecord: 2.8ms)

Are there any other logs to check? It’s strange because I can connect to https://scc.suse.com without any problems.

Please help.

The connection test requests https://scc.suse.com/connect/organizations/subscriptions
This should return a JSON of the available subscriptions for your account.

Do you use a HTTP-Proxy?

I don’t use proxy. If i try to login with my account I get this error:


{“type”:“error”,“error”:“Invalid organization credentials”,“localized_error”:“Invalid organization credentials”}

And I have try to login with different usernames.
I can connect to https://scc.suse.com/ with the same usernames with out a problem.


When you login to the portal with your username, you will find your “organization credentials” those are the ones you need to use.

yes is working now. I didn’t know that you have to search for mirror credentials in suse portal.

Just one more question, can I use Content Views in sles for production and test environment like in RHEL world.

Short answer: Yes.
The plugin creates products and repositories for you. You can use them in content views in much the same way as any other repository.

How can I then use Content Views if there is no activation keys for sles? How can I use this repo from Content Views in zypper repo? Where can I get url?

Hi! After you created and synced your products you might want to use the following documentation:



I have the same pb but i’m using HTTP proxy.
My organization credential are valid and tested on https://scc.suse.com/connect/organizations/subscriptions

Is there any special config to set somewhere to use HTTP Proxy ?


Welcome to the community,

Can you please check if you can save the Account without testing it first and then try to sync it?
We had some problems in the past, where only the Test-button refused to connect via HTTP-Proxy.

Thanks :slight_smile:

Yes i tried but the task end failed and i d’ont know if it’s a config missing or not

Have you tried using the Credentials from the SCC-Account on the mentioned page?
If this also does not work, your credentials are invalid.