Unable to push package updates/errata

I’ve succesfully patched katello to 3.5.1 but i still can’t push package updates and errata to registered hosts. Some hosts are already patched but, just for testing, I installed a new one and if i run “yum update” i get a lot of updates ready to be installed, but in UI under content hosts graphic icons show me “0” for security, bug fix, enhancment and package updates.
Where can i investigate deeper?

Anyone could help me?

You can ssh on to a client and try running the following manually and then re-check the UI:

katello-enabled-repos-upload --force
katello-package-upload --force

Also, if you go to the packages tab for a content host and look at ‘Applicable’ are any listed?

thanks @ehelms. I tried both commands but no packages are marked as “Applicable”. My client host is a CentOS 7 machine. I don’t know if it’s a problem…

On the Monitor > Tasks page, do you see MonitorEventQueue job in a running pending state?

Only this one: Name: Listen on candlepin events {“locale”=>“en”}

“last_message”=>“63a929ad-eee7-3889-8ca2-74f6917e41b6 - compliance.created”,
“last_event_error”=>“undefined method `id’ for nil:NilClass”}

If you do a search for “label ~ Monitor” do you find a MonitorEventQueue task? If so, what state is it in?

I found one task for that label. It’s in running state and pending. Anyway I rebooted server and now in UI i see upgradable packages…

This might have been a by-product of the upgrade and a service, likely dynflow, not getting restarted at the proper time potentially.

Indeed…thanks @ehelms for your support.