Unable to see classes on host edit page

I’m not sure exactly what changed (granted, this is an old environment), but the “Host Edit” page, no longer has a classes tab! If I look at the raw HTML, I see the classes so I know Foreman knows about them, but there’s no tab (no HTML to display it).

Around the time the problem started, I was trying to fix a puppet class import failure, but I don’t remember changing anything… obviously I did! Puppet proxy is functional and serving hosts.

Foreman 1.2.2, proxy 1.2.1, puppet 3.4.3

I’ve looked at the code, but don’t know Ruby and am pretty bad at JavaScript and CSS, which seems to run everything. I suspect it’s a simple fix, I just can’t figure it out!

(and yes, I promise to upgrade to a current environment soon!)

1.2.2? If that’s not a typo, it’s really hard to know. Feels like 1.2 and 1.21 are completely different code bases :slight_smile:

Just confirmed via web page 1.2.2 (previously I used rpm)

What’s interesting is “About/System Information” shows a copyright date of 2009-2019… I guess it’s just specifying the current year. :slight_smile:


In an unrelated issue, last night Window’s update killed the virtual desktop I normally use. In order to get the version number for the previous post I used a “jump host” desktop which only has IE.

After reading the version, I decided to try “edit host” from there and low and behold puppet classes are reported!!! I even tried a puppet class import and that works too! I’ve been fighting this for weeks!

So, at this point I’m 95% sure the issue is current versions for Firefox (and maybe Chrome… I think I tried it too), not specifically a Foreman issue.

I think this is the first case in history of something working in IE and not FF :rofl:

In any case, I’m afraid that 1.2 is so long out of support (in fact, it is so old it took me a while to find that it came out almost 6 years ago!) that no-one will know how to help you with this issue other than suggesting to upgrade.