Unable to send puppet reports to foreman

Nevermind, got it to work. Looks like I messed up the renaming of that
file. I moved it to foreman.rb instead of foreman-report.rb and seems to
be working now. Will try some other things and see how this works.


··· On Thursday, February 7, 2013 2:27:08 PM UTC-8, Jagga Soorma wrote: > > Hi Guys, > > I am a new puppet user and trying to see the different options for > reporting. I was able to setup and use puppet-dashboard just fine but > can't seem to now get reports sent to foreman. Here is what my setup looks > like: > > puppet server: ssfpuppetd01 > foreman server: ssftmand01 > > I have copied foreman-report.rb to the /usr/lib/ruby/site_ruby/1.8/ > puppet/reports directory on my puppet server ssfpuppetd01. The only thing > that I changed in the foreman-report.rb file is the url: > > $foreman_url='http://ssftmand01:3000' > > Here is my puppet.conf on my puppet server: > > [main] > logdir = /var/log/puppet > rundir = /var/run/puppet > ssldir = $vardir/ssl > > [agent] > classfile = $vardir/classes.txt > localconfig = $vardir/localconfig > > [master] > reports = log, foreman > > On my foreman server ssftmand01 I installed foreman and mysql db. I have > updated the /etc/foreman/settings.yaml and /etc/foreman/database.yaml > files. Here is my settings.yaml file: > > :unattended: false > :login: false > :require_ssl: false > :locations_enabled: false > :organizations_enabled: false > :support_jsonp: false > :puppet_server: ssfpuppetd01 > :email_reply_address: Foreman-noreply@xyz.com > > I have started the foreman services on ssftmand01 but it has not puppet > services running. Not sure if that is also needed. With this setup I > still can't seem to get any reports in foreman. I am pretty sure that I am > missing something here and would really appreciate some help to get this to > work. I want to use foreman just as a reporting tool for puppet and would > not like to use the provisioning options. > > Thanks. >