Upgrade 1.16 -> 1.17 fails


When I try to run foreman-rake db:migrate, I get the error:

rake aborted!
Gem loading error: libruby.so.2.2: cannot open shared object file: No such file or directory - /opt/theforeman/tfm/root/usr/lib64/gems/ruby/qpid_messaging-0.34.1/cqpid.so

Any idea what I can do to fix this?

That file should be provided by tfm-rubygem-qpid_messaging, is that package installed? You could try “yum reinstall tfm-rubygem-qpid_messaging”

That package is installed and at the correct version

[jshewey@server ~]$ rpm -qa | grep tfm-rubygem-qpid_messaging

When I reinstall and re-run foreman-rake db:migrate, I still get the same error.

Perhaps it is also worth noting that I was getting the error

Gem loading error: Unable to activate katello-3.5.2, because foreman-tasks-0.11.2 conflicts with foreman-tasks (< 0.11), foreman_docker-4.0.0 conflicts with foreman_docker (< 4)

and to fix it, I had to update /opt/theforeman/tfm/root/usr/share/gems/specifications/katello-3.5.2.gemspec to allow the correct versions?

I also have this issue if I do a katello-backup and katello-restore on a freshly installed instance (not a straight upgrade) - though my upstream repos are coming form an upstream foreman instance. They all look to be at the correct releases/versions upstream though…