Upgrade 1.7.5 -> 1.8.2 fails because of wrong "rubygem-locale"

Hello all,

I wanted to upgrade our Foreman installation to the current release.

Unfortunately there seems to be some kind of version conflict.

–> Processing Dependency: rubygem(locale) >= 2.0.6 for package:
–> Finished Dependency Resolution
Error: Package: rubygem-hammer_cli-0.2.0-1.el6.noarch (foreman)
Requires: rubygem(locale) >= 2.0.6
Installed: rubygem-locale-2.0.5-1.el6.1.noarch (@epel)
rubygem(locale) = 2.0.5-1.el6.1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Right before I did (as said in the documentation)

yum upgrade
yum clean all

I'm using CentOS 6.6 with epel-Repo.

How can I fix this?

Thanks for your help,


> How can I fix this?

I don't know what caused this, but you should be able to uninstall
hammer and its dependency from the system, perform an upgrade and then
install it back perhaps?

··· -- Later, Lukas #lzap Zapletal