Hello, i try an upgrade from 1.17 to 1.18 but i get lots of dependency errors. https://pastebin.com/qjfhn3Qk OS: Debian stretch, upgrade from 1.16 to 1.17 worked, installed by apt, with discovery and ansible plugin afaik, maybe more plugins
Working Foreman as after upgrade from 1.16 to 1.17 a few minutes before
Foreman and Proxy versions:
Foreman and Proxy plugin versions:
Other relevant data:
[e.g. logs from Foreman and/or the Proxy, modified templates, commands issued, etc]
https://github.com/seattlerb/ruby_parser/issues/253 might make debugging hard here… Anyway, please
export DEBUG=1 in your root shell and then
dpkg --pending --configure, there should be some more output pointing to the real issue.
Bundler could not find compatible versions for gem “dynflow”:
Bundler::VersionConflict: Bundler could not find compatible versions for gem "dynflow":
dynflow (< 2.0.0, >= 1.0.0)
foreman-tasks (= 0.13.2) was resolved to 0.13.2, which depends on
dynflow (>= 1.0.5, ~> 1.0)
foreman_ansible (= 2.0.1) was resolved to 2.0.1, which depends on
dynflow (~> 0.8.14)
foreman_remote_execution (= 1.5.4) was resolved to 1.5.4, which depends on
dynflow (< 2.0.0, >= 1.0.1)
thats the problem i think.
Allright, we’ll need to release a new version of the ansible plugin and then DEB package it, we are on it now.