Upgrade from Katello 3.12 to 3.13

When i run the foreman-installer foreman-installer --scenario katello --upgrade it stops with a error.

According to the log file (i hope i can read it well), it stops with the following error:

[ERROR 2019-11-05T16:23:32 main]  /Stage[main]/Pulp::Config/Selboolean[pulp_manage_puppet]: Could not evaluate: Execution of '/usr/sbin/getsebool pulp_manage_puppet' returned 255: Error getting active value for pulp_manage_puppet

I only know little of selinux, but i run it permissive.

I figured the following, when i run semodule -l i get the following error:

libsemanage.semanage_direct_get_module_info: Unable to read candlepin module lang ext file.
semodule:  Failed on list!

All katello/foreman related files in /etc/selinux/targeted/active/modules/400/* are 0 bytes. When i move them away the semodule listing works but the installer still fails…

Does anybody has a hint?

I love it, a lot of time after i post a question, i find the solution/workaround…

I was able to fix it with the following procedure:

  • moved away the corrupt 0 byte files in /etc/selinux/targeted/active/modules/400/
  • semodule -i /usr/share/selinux/targeted/katello.pp.bz2 
    semodule -i /usr/share/selinux/targeted/pulp-server.pp 
  • to be on the save side i reinstalled all selinux policies

After that /usr/sbin/getsebool pulp_manage_puppet and the upgrade went trough…

1 Like