Upgrade issues for 1.20.0-RC1


I can’t execute Ansible roles after the upgrade

Expected outcome:

Selecting “Run Ansible Roles” executes job to apply Ansible roles successfully

Foreman and Proxy versions:


Foreman and Proxy plugin versions:

foreman-tasks: 0.14.1
foreman_ansible: 2.2.9
foreman_hooks: 0.3.14
foreman_memcache: 0.1.1
foreman_remote_execution: 1.6.4

Other relevant data:

Debug log info:

I’m guessing this is on CentOS 7 from the file paths, but could you confirm this?

That’s correct. It’s CentOS Linux release 7.5.1804 (Core).

The error message I’m seeing in the web UI is:

Failed to initialize: RuntimeError - The only applicable proxy localhost is down

I tried starting foreman-proxy and smart_proxy_dynflow_core, but that didn’t seem to work.

Cool, I resolved the issue by running foreman-installer again. Is there any info. I can provide to you guys to help identity the source of the issue?

Did you run the installer after the first upgrade or was that only a yum update? Also wondering if you have the installer log to see what changed to fixed it.

Hmmm… I might have missed Step 3 C.
Is there a way to redact hostnames with foreman-debug?