User-group list can not find a valid user-group

Problem: In my .hammer/defaults.yml file, I have the organization, organization id and location defined. I cloned a role and set its ID to ROLID. I then ran:
hammer user-group create --admin true --name myadmins --role-ids %{ROLID}

It created the group. When I run:
hammer user-group list

I get back association not found for location. I tried adding in the --no-use-defaults and it showed the user group. I then deleted the user-group and then re-created adding:

hammer user-group create --admin true --name myadmins --location-id ${LOCID} --organization-id ${ORGID} --role-ids %{ROLID}

and it again created the group. However, hammer user-group list again failed. I then added the --no-use-defaults and it showed it.

Expected outcome: The user-group gets created within my default organization and location and displays when I enter a hammer user-group list.

Foreman and Proxy versions: 2.3.3-1

Foreman and Proxy plugin versions: katello 3.18.2-1

Distribution and version: CentOS 7.9

Other relevant data: