After adding a CentOS 7 host to Foreman I am getting a warning about the katello-host-tools


#1

Problem:
Could not calculate errata status, ensure host is registered and the katello-host-tools package is installed.

I am able to successfully see the host in Content Hosts, and it is subscription status is green. But when I go to All Hosts it is marked with that warning.

I also can’t run any remote execution jobs, these two maybe tied together.

Expected outcome:

Foreman and Proxy versions:
Don’t have the smart proxies installed.
Foreman-Katello - 1.22.0
Foreman and Proxy plugin versions:
foreman-tasks - 0.15.5
foreman_ansible - 3.0.2
foreman_remote_execution - 1.8.0
katello - 3.12.0

Other relevant data:
This is an out put of Katello on the target host that is having an issue.
rpm -qa | grep katello
katello-client-repos-3.8.1-1.el7.noarch
katello-host-tools-fact-plugin-3.3.5-4.el7.noarch
katello-ca-consumer-nhifformkat01.nh.corp-1.0-1.noarch
katello-host-tools-3.3.5-4.el7.noarch
katello-agent-3.3.5-4.el7.noarch
katello-host-tools-tracer-3.3.5-4.el7.noarch

logs

Warning, Could not calculate errata status, ensure host is registered and the katello-host-tools package is installed
#2

Here is a screenshot. error-errata

It shows up fine in Content Hosts though. Please excuse my ignorance I am very new to Foreman trying to manage our neglected in Linux environment.

I covered the names for obvious reasons.


#3

Hi,

first off, since you did not elaborate on this, have you done what the warning told you and checked if the tools are installed and the system is properly registered?
You can check this the following way:
On the system you want to manage, rpm -qa | grep katello shoud list one package with a name like katello-ca-consumer-* as well as at least katello-host-tools (probably some more packages related to the host tools). subscription-manager status should show “Overall Status: Current” and subscription-manager identity should show you the Org name the system is registered to as well as an environment name in the form of < Lifecycle Environment >/< Content View >.
Can you verify these are all correct?

Second, you should have a foreman-proxy, since the main instance also has one with some plugins by default (if not, a lot of functionality will definetly be broken). You can check under Infrastructure -> Smart Proxies in the UI for that. Please note that it might be necessary to switch to “Any Location”/“Any Organization” in the dropdowns in the top bar right next to the Foreman logo (depending on how far you are with your setup). If you only see a proxy when in the “Any” context, it’s probably best to assign Org/Loc right away in the proxy’s settings.

Concerning the problem with remote execution:
On your Foreman server, you should have the following packages installed (versions will most likely differ for you)

rpm -qa | grep remote
rubygem-smart_proxy_remote_execution_ssh-0.2.0-2.el7.noarch
tfm-rubygem-foreman_remote_execution-1.6.7-1.fm1_20.el7.noarch
tfm-rubygem-foreman_remote_execution_core-1.1.4-1.el7.noarch

rpm -qa | grep dynflow
rubygem-smart_proxy_dynflow-0.2.1-1.el7.noarch
tfm-rubygem-smart_proxy_dynflow_core-0.2.1-1.fm1_20.el7.noarch
rubygem-dynflow-0.8.34-2.fm1_17.el7.noarch
tfm-rubygem-dynflow-1.1.2-1.fm1_20.el7.noarch

If not, you probably have not setup remote execution plugin correctly.
If have installed everything, there are some more error sources that are best troubleshootet with more information on what you mean exactly with “can’t run remote execution jobs”.

Regards


Warning, Could not calculate errata status, ensure host is registered and the katello-host-tools package is installed