"All Puppet Classes" greyed out

When I click on a host to get host details, the button for "All Puppet
Classes" is greyed out. When I click on it, I get, "We're sorry, but
something went wrong. We've been notified about this issue and we'll take a
look at it shortly." Is this expected behavior?

(Running 0.3)
Thanks,
Brian

··· --

> When I click on a host to get host details, the button for "All Puppet Classes" is greyed out. When I click on it, I get, "We're sorry, but something went wrong. We've been notified about this issue and we'll take a look at it shortly." Is this expected behavior?
> (Running 0.3)

··· On Aug 23, 2011, at 7:18 PM, Brian Gupta wrote: ---- No - there's something wrong with your setup... perhaps FOREMAN_ROOT/config/settings.yaml

Craig

Or maybe he is running into an actual issue: Bug #973: Error 500 when click "All Puppet Classes" - Foreman

The fix-it-yourself if you ARE configured correctly is:
http://theforeman.org/projects/foreman/repository/revisions/6fc77b66f857e0a34ec46c7f56dfbc52fbac035b
(look at the diffs)

Regards,
Jake

··· On Aug 24, 10:20 am, Craig White wrote: > On Aug 23, 2011, at 7:18 PM, Brian Gupta wrote: > > > When I click on a host to get host details, the button for "All Puppet Classes" is greyed out. When I click on it, I get, "We're sorry, but something went wrong. We've been notified about this issue and we'll take a look at it shortly." Is this expected behavior? > > (Running 0.3) > > ---- > No - there's something wrong with your setup... perhaps FOREMAN_ROOT/config/settings.yaml > > Craig

We are going to upgrade to latest git version, and see if this is resolved.
(There are a number of fixes and features we want, so this just puts us over
the edge)

Thanks, Brian

··· On Wed, Aug 24, 2011 at 11:39 AM, Jake - USPS wrote:

Or maybe he is running into an actual issue:
Bug #973: Error 500 when click "All Puppet Classes" - Foreman

The fix-it-yourself if you ARE configured correctly is:

Revision 6fc77b66 - fixes #973 - Error 500 when click "All Puppet Classes" - Foreman
(look at the diffs)

Regards,
Jake

On Aug 24, 10:20 am, Craig White craig.wh...@ttiltd.com wrote:

On Aug 23, 2011, at 7:18 PM, Brian Gupta wrote:

When I click on a host to get host details, the button for “All Puppet
Classes” is greyed out. When I click on it, I get, “We’re sorry, but
something went wrong. We’ve been notified about this issue and we’ll take a
look at it shortly.” Is this expected behavior?

(Running 0.3)


No - there’s something wrong with your setup… perhaps
FOREMAN_ROOT/config/settings.yaml

Craig


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To post to this group, send email to foreman-users@googlegroups.com.
To unsubscribe from this group, send email to
foreman-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/foreman-users?hl=en.


http://aws.amazon.com/solutions/solution-providers/brandorr/