Ansible plugins

The instructions to install the ansible plugin do not work for the latest version of foreman on CentOs 7.5

Is anyone else having these issues?

Expected outcome:

Foreman and Proxy versions:

Foreman and Proxy plugin versions:

Other relevant data:


could you provide more details about how it does not work?

None of the plugins will install.

When you run foreman-install --enable-name of plugin it can’t find them and when you do a search for them, they’re not present, others are but none of the Ansible ones.

There are no tpm packages in the repo and if you try to install what’s present in the repo, it fails due to dependencies that don’t exist or don’t work with the current version.

I assume by “latest” you mean Foreman 1.20 and not nightly. There are two problems in what you described. First is missing options in installer and second is missing dependencies.

What version of foreman-installer package do you have?

For the dependencies, do you have the foreman-release-scl package installed?

Correct. The version of Foreman is 1.20

If I try to run foreman-installer --enable-foreman-plugin-ansible --enable-foreman-proxy-plugin-ansible to install ansible, I get the following…

ERROR: Unrecognised option ‘–enable-foreman-plugin-ansible’

See: ‘foreman-installer --help’

I do have foreman-release-scl installed and the foreman-installer version is 1.9.

The package that it asks me to install… tfm-rubygem-foreman_discovery, fails with all kinds of dependencies listed below. I do have foreman-release-scl installed.

Resolving Dependencies
–> Running transaction check
—> Package ruby193-rubygem-foreman_discovery.noarch 0:4.0.0-1.fm1_9.el7 will be obsoleted
—> Package tfm-rubygem-foreman_discovery.noarch 0:14.0.0-1.fm1_20.el7 will be obsoleting
–> Processing Dependency: foreman >= 1.20.0 for package: tfm-rubygem-foreman_discovery-14.0.0-1.fm1_20.el7.noarch
–> Processing Dependency: tfm-runtime for package: tfm-rubygem-foreman_discovery-14.0.0-1.fm1_20.el7.noarch
–> Processing Dependency: rh-ruby25-ruby(rubygems) for package: tfm-rubygem-foreman_discovery-14.0.0-1.fm1_20.el7.noarch
–> Processing Dependency: rh-ruby25-ruby(release) for package: tfm-rubygem-foreman_discovery-14.0.0-1.fm1_20.el7.noarch
–> Processing Dependency: rh-ruby25-ruby for package: tfm-rubygem-foreman_discovery-14.0.0-1.fm1_20.el7.noarch
–> Finished Dependency Resolution
Error: Package: tfm-rubygem-foreman_discovery-14.0.0-1.fm1_20.el7.noarch (foreman-plugins)
Requires: rh-ruby25-ruby(release)
Error: Package: tfm-rubygem-foreman_discovery-14.0.0-1.fm1_20.el7.noarch (foreman-plugins)
Requires: rh-ruby25-ruby(rubygems)
Error: Package: tfm-rubygem-foreman_discovery-14.0.0-1.fm1_20.el7.noarch (foreman-plugins)
Requires: rh-ruby25-ruby
Error: Package: tfm-rubygem-foreman_discovery-14.0.0-1.fm1_20.el7.noarch (foreman-plugins)
Requires: foreman >= 1.20.0
Installed: foreman-1.9.3-1.el7.noarch (@foreman)
foreman = 1.9.3-1.el7
Available: foreman-1.9.0-0.1.RC1.el7.noarch (foreman)
foreman = 1.9.0-0.1.RC1.el7
Available: foreman-1.9.0-0.1.RC2.el7.noarch (foreman)
foreman = 1.9.0-0.1.RC2.el7
Available: foreman-1.9.0-0.1.RC3.el7.noarch (foreman)
foreman = 1.9.0-0.1.RC3.el7
Available: foreman-1.9.0-1.el7.noarch (foreman)
foreman = 1.9.0-1.el7
Available: foreman-1.9.1-1.el7.noarch (foreman)
foreman = 1.9.1-1.el7
Available: foreman-1.9.2-1.el7.noarch (foreman)
foreman = 1.9.2-1.el7
Error: Package: tfm-rubygem-foreman_discovery-14.0.0-1.fm1_20.el7.noarch (foreman-plugins)
Requires: tfm-runtime
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodiges

You’re trying to install foreman 1.20 with installer for foreman 1.9. I would be really surprised if that worked. Could you first update foreman-installer to match the version you’re trying to install and try again?

There is no foreman-installer 1.20. Its not in the repo. None of the repo’s that I point to have the correct packages.

The repository you linked is for 1.9. Of course there is not 1.20 installer in there. It looks as if you have 1.20 plugin repo enabled.

Even when i point it to the 1.20 repo, it doesn’t install because it fails with more dependencies that do not exist and then I try to find a repo to point to for those dependencies and I get a few but then it fails because of other dependencies. It seems like a never ending rabbit hole.

The instructions listed on the website are innaccurate to install ansible-plugins with the latest version of theforeman.

1 Like

I made the same experience today.
I tried to install foreman on a fresh installed ubuntu 18.04.2 and on a debian 9.7
The installation of the foreman installer from repos 1.20 was successfull. But everytime when i try to install the ansible plugin from the foreman-ansible plugin manual page the foreman installer failed. I really just followed the official manual. A little disapointed now :frowning:
For Ubuntu there was an error with concurrent ruby package. I found some information about the error on google from 2015 but no solution.

good 2 know i’m not the only one. it needs to be updated. let me know if you have any luck.

I spent one complete day just with searching an error in my config and with google for the error output. There was nothing that helped me to understand the exact problem. I will start a new thread here with the exact error message. I hope someone has any idea.

I’m sorry, we’re aware of this issue on deb based installations now. This should be already fixed in 1.21, that is about to be released. If we find more time, we will take a look on backporting to 1.20, but we now focus on new version.

1 Like

Hi there, so happy to read this. Thanks so much. So then I will wait for 1.21