Ansible-test conflict with RHEL8.6 and derivates

It seems that RHEL 8.6 now contains ansible in AppStream. It provides version 2.12.2. The foreman installation docs for version 3.2 enable ansible 2.9 repositories.

This leads to a conflict when upgrading to 8.6, e.g. on AlmaLinux

 Problem: package ansible-test-2.12.2-3.1.el8.x86_64 requires ansible-core = 2.12.2-3.1.el8, but none of the providers can be installed
  - package ansible-core-2.12.2-3.1.el8.x86_64 conflicts with ansible < 2.10.0 provided by ansible-2.9.27-1.el8.noarch
  - cannot install the best update candidate for package ansible-test-2.9.27-1.el8.noarch
  - cannot install the best update candidate for package ansible-2.9.27-1.el8.noarch

The ansible 2.9 repository installed packages ansible and ansible-test.

Now there is ansible-core and ansible-test 2.12.2 available in appstream.

The appstream ansible-core package doesn’t upgrade the ansible package from the 2.9 repository.

As both repositories have ansible-test in different versions it breaks…

That’s correct. Please follow the documentation of your distribution (like Using Ansible in RHEL 8.6 and later - Red Hat Customer Portal) how to upgrade from Ansible 2.9 to 2.12.

TL;DR: dnf install ansible-core ansible-test --allowerasing should do it.

1 Like

Excellent.

# dnf install ansible-core ansible-test --allowerasing

did the trick. I guess that means docs need to be updated. The install docs should not install centos-release-ansible-29 and the upgrade docs should mention this issues and the solution…

Well, on fresh installs the ansible-29 repo doesn’t hurt (and that way the docs also work for 8.5).

As for upgrades… I’d think OS upgrades should be documented by the OS vendor? :wink:

Hit the same issue on AlmaLinux 8.5. Performed this on my Foreman server

[root@foreman ~]# dnf update ansible-test --allowerasing
Last metadata expiration check: 0:02:25 ago on Fri 13 May 2022 12:36:58 PM UTC.
Dependencies resolved.
=====================================================================================================================
 Package                   Architecture Version                                       Repository                Size
=====================================================================================================================
Upgrading:
 ansible-test              x86_64       2.12.2-3.1.el8                                appstream                663 k
Installing dependencies:
 ansible-core              x86_64       2.12.2-3.1.el8                                appstream                2.4 M
 emacs-filesystem          noarch       1:26.1-7.el8                                  baseos                    69 k
 git                       x86_64       2.31.1-2.el8                                  appstream                160 k
 git-core                  x86_64       2.31.1-2.el8                                  appstream                4.7 M
 git-core-doc              noarch       2.31.1-2.el8                                  appstream                2.6 M
 perl-Error                noarch       1:0.17025-2.el8                               appstream                 46 k
 perl-Git                  noarch       2.31.1-2.el8                                  appstream                 77 k
 perl-TermReadKey          x86_64       2.37-7.el8                                    appstream                 40 k
 python38-psutil           x86_64       5.6.4-4.module_el8.6.0+2778+cd494b30          appstream                406 k
 python38-resolvelib       noarch       0.5.4-5.el8                                   appstream                 29 k
Removing dependent packages:
 ansible                   noarch       2.9.27-1.el8                                  @centos-ansible-29        96 M

Transaction Summary
=====================================================================================================================
Install  10 Packages
Upgrade   1 Package
Remove    1 Package

Total download size: 11 M

Just used the update command but same result. :slight_smile: