Applicable rpms listed from inactive module streams Remi Repo


I’ve added Remi Repo Modular EL8 and enabled remi-php7.4 Module Stream
But Katello shows applicable Packages php8.0/php8.1
These Module Streams are not enabled

If i do a
dnf update on the system, DNF correctly recognize there are no updates available for remi-php7.4

Expected outcome:
Dont show diabled AppStream Packages as applicable

Foreman and Proxy versions:
Katello 4.22
Foreman 3.0.1

Foreman and Proxy plugin versions:

Distribution and version:

Almalinux 8.5

Other relevant data:

I’ve upgraded Katello from 4.1 to 4.2
Problem already existed in latest 4.1

Hello again,

this Problem gets super annoying.
I even created a filter and excluded all remi-php8 and remi-php8.1 module streams

these module streaems does not show up when i do
dnf module list
on an client

but still php8.x shows as applicable

i even diabled remi repo all together,
dnf uploadprofile --force-upload

re added remi repo

and its still showing php8.x as applicable

Hi @dodo

thanks for reporting this! We’re going to see if we can reproduce the issue. Is that repo publicly available somewhere?

1 Like

thank you,

please let me know if i can help you to figure this out.

Remi Repo is a known PHP Repo

affected Modular Repo

just want to check in and see if you found something?

Do i need to provide more information?

Thank you

Hi @dodo

We just haven’t gotten a developer to look at it yet. It’s on our to-do list.

I created Bug #34487: Katello shows RPMs from non-enabled module streams as applicable - Katello - Foreman

so the issue can be tracked.

1 Like

@dodo I can’t re-produce the issue with Katello 4.2 and your provided Remi repo.

Does the issue still exist in your environment?

Thank you for looking into this.

sadly yes, still same issue

Any tips for troubleshooting this further?

Thank you !

Just to make sure
you did install some php74 packages?


The php packages installed locally:

[vagrant@rhel85 ~]$ rpm -qa |grep php

Could you try disable then re-enable your php module stream?
If it still doesn’t work, could you try with a refresh new foreman/katello environment?
Please keep us updated.
Thank you.

@dodo Any update? Were you able to resolve it?

1 Like


sorry for tha late reply
i was on vacation

could test ist yet, so sorry

Thanks for all your help

ich try to test ASAP

Thank you


i just installed katello
added remi repo safe + modular (same as at work)
installed some packages

everything is fine like you said…

it seems to some problem with calculating applicable packages…maybe something went wrong with some updates ( this installation is since 3.8)

can you please guide me to do some troubleshooting?
maybe just some bad DB entrys?

thank you


At Work i’m on same version
Issue still persist

I also tried to unsubscribe the Host and re added it
did some subscripiption-manager refresh --force tries
still same issue
If needed i can provide full detailed troubleshooting steps for subscription-manager
it’s still happening when i subscribe a new fresh host …

maybe i will try and recreate the whole PHP “Product” disable the old and enable the new repo’s

maybe it’s worth a try
i will report back

Problem is solved
I recreated the Remi Modular Repositories and now everything show up as expected

Thank you

1 Like