At wits end - Please help - can't get proxies to sync continuous pulp errors

The bandwidth is restricted although I’m using an optimised sync now. However I cant sync multple proxies and different sites at the same time as it takes even longer. They just get queued up
The main strange tihng about this proxy is that although the job completes 100% its show up at 79%.
I have 3 lifecycle content attached but it says it can only sync 2. Ive tried removing and adding the missing content.

@sinewave I’m circling back through some open issues - did this resolve in due course or is it something you continue to struggle with?

As you’re using a slow network connection, I would recommend using some strategies to reduce the amount of data that needs to be downloaded. If you download the entire RHEL 7 repository for example, you’re downloaded getting many thousands of historical packages which are probably not relevant. If you use the retain_package_versions option and select a number like 1, 2, or 3 (most recent) packages, the size of your total repo download will drop by something like 80%, IIRC it is roughly a drop from 60 Gb to 10 Gb of data that needs to be downloaded.

Hi I think I’ve got a handle on most of these problems. there are still niggles but overall I have been able to work around them.
I recently had to remove all lifecycles from a proxy full sync then add the failing error 404 do a full sync of that one only. Which resolved the issue.

Where is the retain_package_version option I dont see that in the products area ?

Perhaps it depends on which version you are running, you may not have the functionality. @iballou Do you know if / where they can find this option?

@iballou is this a katello 4 only feature ?

I didn’t notice at the time but he’s on leave until next week.

Hi @sinewave, it looks like the retain package versions feature only made it into Katello 4.2+


If I upgrade to this version and use retain function will the existing packages get automatically purged when you sync the product repositories ?

That should be the case, yes.

1 Like

If you’re upgrading to 4.2, I’d recommend going up to at least 4.4. We consider the latest two releases to be the ones that are “in support”.

Also, there is a known issue with “retain package versions” and “additive” repositories. It was fixed, but the fix is currently only in 4.6. It should eventually make it to 4.5.1. Bug #35120: Retain packages on Repository removes RPMs from Pulp but not from Katello - Katello - Foreman

1 Like

ok thanks @iballou
Is it advisable to go straight to 4.6 as I would really like this feature.

one quick question going back to pulp workers. I only recently noticed this.
when I run foreman-maintain health check
I get this :
Following services are not running: pulpcore-worker@*

looking at my systemd file I have
pulpcore-worker@.service - what is this ? should this be removed ?
pulpcore-worker.service - which I edited as per this thread.

Hi @sinewave ,

4.6 is still in the RC phase I believe, so I would go to 4.5. You’ll need to upgrade version-by-version up to 4.5.

The pulpcore workers are numerous and there can be any number of them. That’s what the @* sign represents, essentially. You’ll likely have one worker per CPU core. So, you should see pulpcore-worker@1, pulpcore-worker@2, …

Were any of your workers running? Try running systemctl restart pulpcore-worker@* --all if they aren’t.

On my system, I have /etc/systemd/system/pulpcore-worker@.service

1 Like