Big provisioning libraries update and test


#21

Nightly repos are updated. I successfully installed Foreman from this repo. The testing of core compute resources can start! There’s still some work pending on GCE and Azure, potentially also oVirt. So at this time, I’d like to ask everyone who can spend some time on testing VMware, libvirt, openstack, aws to do so with the nightly version and share their findings here. Information about xenserver, rackspace, digital ocean would also be great.

@sghai, @san7ket please let me know if you need any help with setting up Foreman nightly instance.Your and anyone else help would be greatly appreciated.


#22

Awesome. The fog update was long overdue and this still gives us a bit of time to stabilize 1.22.


#23

Nice. thanks Marek. I’ll ask folks to spend some time and test out these.


#24

Keep in mind that updated katello nightlies have still not been published due to failing tests, will hopefully get them working as well soon.


#25

Hey @tbrisker I the nightly job fails for me with issue, would this be the similar issue you are talking about

ackage: tfm-rubygem-katello-3.12.0-0.4.pre.master.20190320112612gita2bc3e2.el7.noarch (katello)
out:                Requires: foreman-webpack-vendor-js(6b0ab2f2e5905ecd8e45)
out:     **********************************************************************
out:     yum can be configured to try to resolve such errors by temporarily enabling

#26

yes, those are the failures- as you can see from the timestamp, the katello nightly is from March 20th which is the last date we had successfully built katello nightlies. @ehelms and @Justin_Sherrill are working on fixing this afaik.


#27

Yes, katello needs new build in nightly and is/was blocked on some failures after bastion was merged. You can install Foreman core without plugins, for testing most things with core compute resources, that is enough.


#28

Great, I wonder if we shall plan the next update after 1.23 is branched out so we can coordinate similar but hopefully less painful upgrade with QA to avoid falling back too behind. Probably to put this to branching document we have?


#29

AWS looks good.
Tested:
CR creation
VM list
Image Creation
Image based provisioning looks good.


#30

Openstack test results.

Openstack v10:

Test Successful:

  • Able to create CR
  • Able to see list in create CR
  • Able to create Image
  • Able to create VM
  • Able to see Created VM under CR and take the console [Infrastructure => Compute Resource]
  • Able to take console from VM. [Hosts => All hosts => VM name => Console]
  • Able to power on/off
  • Able to unprovision/delete VM

Test failed:

  • Refresh Cache button does not work and after click failed with below error (Not sure if that should work for Openstack) ?

    Error:

      ERF42-7329 [Foreman::Exception]: Not implemented for OpenStack
      Extracted source (around line #305):
      def refresh_cache
      raise ::Foreman::Exception.new(N_("Not implemented for %s"), provider_friendly_name)
      end
  • Selected values shows deselected after VM create:
    i.e. create a VM, Click on edit(hosts => All hosts => VM name => edit) and see the below values under “Virtual Machine” tab

Security groups
Internal network
Floating IP network

Openstack v13:

Compute resource create fails with below error however same provided URL/username/Password/Domain works fine with Foreman v 1.20.

Expected([200, 201]) <=> Actual(401 Unauthorized) excon.error.response :body => "{“error”: {“message”: “The request you have made requires authentication.”, “code”: 401, “title”: “Unauthorized”}}


#31

I can confirm tnis is “not implemented” error. We are simply not there yet.

Not following can you elaborate please?

What do you use for the URL? Please note the helper text, there are some assumptions now, you must not enter any kind of /v2 or /v3 suffixes, just put there http://hostname:port and that’s it. The code now detects automatically openstack version.


#32

Should we display the button if it doesn’t work?


#33

[vijsingh] Yeah , I tried with /v3 because same is mentioned in eg[ e.g. http://openstack:5000/v2.0/tokens or http://openstack:5000/v3/auth/tokens] under url .I have given a try using http://hostname:port but still same error.


#34

If the way we specify url’s have changes, could we also update the help text for OSP
it stills shows : e.g. http://openstack:5000/v2.0/tokens or http://openstack:5000/v3/auth/tokens


#35

Sorry to mislead you, actually the code has been changed and it requires to have either /v2 or /v3 to be present in the URL to differentiate the versions.

Well, I can’t test RHOSP v13 as I don’t have an account on any v13 instance. So I have no idea what is wrong :frowning:


#36

I can hook you up :slight_smile: with a OSP probably on monday. Can you give it a try ?


#37

Good idea , as that could help to move further on it.


#38

Let me know I am interested in getting access to v13.