Bluecat plugin

Installed proxy plugin ‘smart_proxy_dhcp_bluecat’ by m4c3. I cloned git repository, installed gem, made config file. Proxy log shows:

[E] Disabling all modules in the group [‘dhcp_bluecat’, ‘dhcp’] due to a failure in one of them: uninitialized constant BlueCat

Expected outcome:
Would hope to not see errors :stuck_out_tongue:

Foreman and Proxy versions:

Foreman and Proxy plugin versions:
bluecat plugin 0.1.0

Distribution and version:
CentOS Linux release 7.7.1908
Other relevant data:

I’ve pinged people from Sixt who maintains this plugin. @Susanne @m4c3

Hi, did you complie the gem from master?
can you try the Version from git tag 0.1.0?

Or even the rpm?

1 Like

I did initially compile from master on m4c3’s fork, it seems.

I uninstalled that gem and installed via the 0.1.0 tarball from the theforeman/smart_proxy_dhcp_bluecat, but I’m seeing the same behaviour ("…due to a failure in one of them: uninitialized constant BlueCat").

Output from installation (from 0.1.0 tarball)

# gem install --ignore-dependencies smart_proxy_dhcp_bluecat                                                                                                     
Fetching: smart_proxy_dhcp_bluecat-0.1.0.gem (100%)
Successfully installed smart_proxy_dhcp_bluecat-0.1.0
Parsing documentation for smart_proxy_dhcp_bluecat-0.1.0
Installing ri documentation for smart_proxy_dhcp_bluecat-0.1.0
Done installing documentation for smart_proxy_dhcp_bluecat after 0 seconds
1 gem installed

(for the record, I also have tried master from the main git repo with the same result)

Let’s do a debug session. I’ve send you an DM

@rwagner76 and i sorted this out:
in the gem from is an bug the the classnames

after manual building and installing of the builded gem the smartproxy could load the plugin.

i will update the gem on to a new version and try to get it packaged too