Boot errors with Discovery

I’m trying to get started with Foreman and the first thing I want to do is setup discovery so I can get hosts added. I’m running into problems, once the new host boots and it starts to load Discovery, I get boot errors. I’m running ovirt VMs, so I configured them for both UEFI boot and BIOS boot and both get errors. I assume it’s a configuration problem I have since both boot methods are giving me errors.

UEFI boot error :
EFI stub: ERROR: Failed to alloc mem for kernel

BIOS boot error :
KASLR disabled: ‘nokaslr’ on cmdline

Expected outcome:
New host boots into discovery image, able to be provisioned by Foreman

Foreman and Proxy versions:
Version 2.3.3

Foreman and Proxy plugin versions:
foreman-tasks: 3.0.3
foreman_discovery: 16.3.4
foreman_remote_execution: 4.2.2
katello: 3.18.1

Distribution and version:
Red Hat Enterprise Linux release 8.3 (Ootpa)

Other relevant data:
I’m starting fresh, I have a clean RHEL8 OS install (packages selected @^minimal-environment @standard) and I have an Ansilble script to configure the server to install foreman. I’ve had to do this a few times, so this is repeatable for me. After laying down the base configuration, I install foreman with the following command line.

foreman-installer --scenario katello --foreman-proxy-dhcp=true --foreman-proxy-dhcp-gateway= --foreman-proxy-dhcp-range="" --foreman-proxy-dhcp-nameservers="," --foreman-proxy-tftp=true --foreman-initial-location=Home --foreman-initial-organization=Domain --enable-foreman-plugin-discovery --enable-foreman-proxy-plugin-discovery --foreman-proxy-plugin-discovery-install-images=true --enable-foreman-compute-ovirt

And then I follow Plugin Documentation to set it up. As I write the post, I just realized that I have Discovery plugin 16 installed but I only see version 15 documentation. Hopefully that isnt causing a problem. In the UI, I configured my subnet, ensure the proxies are set to my foreman host, configure “Default PXE global template entry” and then “Build PXE Template”. Very minimal UI configuration at this point.

That leads me to believe that I have a problem only with the PXE boot portion of the Discovery process.

Searching for my boot errors didn’t yield anything insightful and I believe it’s a configuration issue I have with the Discovery plugin. I downloaded the discovery ISO and booted the VM in UEFI mode from that and it worked like a charm. It looks like something is going on in the PXE boot process .
Any insights will be greatly helpful.


Hey, since your env is virtual there is no reason to use EFI. In oVirt the best approach is to simply utilize iPXE which is the default network stack for VMs. That works nicely in BIOS.

So let’s focus on the BIOS error - I have never seen such an error, can you attach screenshot?

How much memory did you give to the VM?

Thanks for the reply Izap, that helped a ton. Well this is embarrassing, I created a small test VM and gave it a small amount of RAM, 512MB. Since you asked about it, I upped that to a more modern 2048MB and worked like a charm. I also swapped the VM over to BIOS, but it was upping the memory that did the trick.

Here’s the screenshot of what I see in the VM console when I didn’t give it enough memory just in case anyone else tries this again.

This happened to all of us, I was trying to boot Linux with 2k of memory instead of 2GB. A typo.

Yeah that message is just the first warning of a booting kernel, then it gets stuck :slight_smile: