Can´t generate bootdisk image

Problem: Oops, we’re sorry but something went wrong ERF42-8203 [Foreman::Exception]: Ensure /var/lib/foreman/bootdisk/grubx64.efi is readable (or update “Grub2 directory” setting)

Foreman version: 3.3.0 with Katello 4.5.0

Bootdisk plugin versions: 19.0.5

Foreman distribution: RedHat 8.6


When I tried to create a bootdisk image to install one host, I obtain the following error:

foreman-rake errors:fetch_log request_id=4f0f9cc6

What does this show? It must be readable by the foreman user, as the error message says.

ls -l /var/lib/foreman/bootdisk/grubx64.efi

Hi Marek_Hulan,

Thanks for your answer. From what I can see I don’t have the bootdisk folder and grubx64.efi file.

I already installed the foreman’s bootdisk, I have the CentOS7 product created and the repository loaded.

Can I create the folder and put the grubx64.efi manually or should this already be there?

Yes, I think you need to deploy the files yourself. I think grub2-efi rpm contains the efi files.

Quoting the information from obsolete foreman-bootloaders repository

Foreman installer now generates grub2 image via grub2-mknetdir command and it is possible to do this on Red Hat systems for multiple architectures. Other bootloaders like grub1 or pxelinux must be acquired from upstream projects.

It’s weird this is not documented anywhere but I didn’t find any code that would do that for the user. @lzap do you happen to know?

Hi All,

I do have the exact same issue. Is there any update on this?

Check SELinux?


I already deployed the files myself and verified the selinux . Aftrer that, when generate the Host Image, I obtained the following error:

Oops, we're sorry but something went wrong ERF42-8203 [Foreman::Exception]: Ensure /var/lib/foreman/bootdisk/shimx64.efi is readable (or update "Grub2 directory" setting)

Lastly, I searched for shimx64.efi on the machine and find the file at /boot/efi/EFI/redhat/. I copied the file to /var/lib/foreman/bootdisk/ and now I’m able to generate Host Images.

NOTE: grubx64.efi is also in the same folder as shimx64.efi (/boot/efi/EFI/redhat/). You can also copy this file to /var/lib/foreman/bootdisk/.

This solved my issue.

Hi Bruno,

right that fixes my error as well :slight_smile:
Would be nice if this is documented as well in the bootdisk plugin.

However many thanks!

I had this same issue when installing/using the bootdisk plugin for the first time on a 3.4/4.6 system.
The fix mentioned above works.

But, I didn’t get the issue when installing the bootdisk plugin on a 3.3/4.5 system.
I have also updated this system to 3.4/4.6 and still no issue.