Cannot use Organizations

Hi All,

I've done a successfull installation of Foreman / Proxy / Puppetmaster, but
I've made a mistake. I didn't configured the Organization enabled, and run
with that settings. When I realized, I've edited the
/etc/foreman/settings.yaml file to :organizations_enabled: true, and
restarted the foreman service - but there wasn't any changes: I still
cannot see it in the web interface, only locations.

After that, I've added Hammer és Hammer for Forman, and try to done it from
CLI - but the server responded with the following:

root@puppet:/etc/foreman# hammer organization list
The server does not support such operation.

My final thought was to run the foreman-installer again, with proper
config, but the results are the same - still cannot add, or edit, or view
any Organizations related informations.

Any idea?

Thank you in advance,

Regards,
Csaba

> Hi All,
>
> I've done a successfull installation of Foreman / Proxy / Puppetmaster,
> but I've made a mistake. I didn't configured the Organization enabled, and
> run with that settings. When I realized, I've edited the
> /etc/foreman/settings.yaml file to :organizations_enabled: true, and
> restarted the foreman service - but there wasn't any changes: I still
> cannot see it in the web interface, only locations.
>
> After that, I've added Hammer és Hammer for Forman, and try to done it
> from CLI - but the server responded with the following:
>
> root@puppet:/etc/foreman# hammer organization list
> The server does not support such operation.
>
> My final thought was to run the foreman-installer again, with proper
> config, but the results are the same - still cannot add, or edit, or view
> any Organizations related informations.
>
> Any idea?
>
> can you paste your config file? maybe a typo?

Ohad

··· On Thu, Dec 5, 2013 at 5:38 PM, wrote:

Thank you in advance,

Regards,
Csaba


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/groups/opt_out.

Hi Ohad,

thank you for your response, see puppet.conf, settings.yaml attached.

regards,
Csaba

  1. december 5., csütörtök 17:01:39 UTC+1 időpontban ohad a következőt
    írta:

puppet.conf (2.63 KB)

settings.yaml (609 Bytes)

··· > > > > > On Thu, Dec 5, 2013 at 5:38 PM, <csaba...@shiwaforce.com >wrote: > >> Hi All, >> >> I've done a successfull installation of Foreman / Proxy / Puppetmaster, >> but I've made a mistake. I didn't configured the Organization enabled, and >> run with that settings. When I realized, I've edited the >> /etc/foreman/settings.yaml file to :organizations_enabled: true, and >> restarted the foreman service - but there wasn't any changes: I still >> cannot see it in the web interface, only locations. >> >> After that, I've added Hammer és Hammer for Forman, and try to done it >> from CLI - but the server responded with the following: >> >> root@puppet:/etc/foreman# hammer organization list >> The server does not support such operation. >> >> My final thought was to run the foreman-installer again, with proper >> config, but the results are the same - still cannot add, or edit, or view >> any Organizations related informations. >> >> Any idea? >> >> can you paste your config file? maybe a typo? > > Ohad > >> Thank you in advance, >> >> Regards, >> Csaba >> >> -- >> You received this message because you are subscribed to the Google Groups >> "Foreman users" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to foreman-user...@googlegroups.com . >> To post to this group, send email to forema...@googlegroups.com >> . >> Visit this group at http://groups.google.com/group/foreman-users. >> For more options, visit https://groups.google.com/groups/opt_out. >> > >

Looks ok - can you try restarting httpd (Red Hat) or apache2 (Debian,
Ubuntu)?

··· -- Dominic Cleal Red Hat Engineering

On 06/12/13 09:05, csaba.sari@shiwaforce.com wrote:

Hi Ohad,

thank you for your response, see puppet.conf, settings.yaml attached.

regards,
Csaba

  1. december 5., csütörtök 17:01:39 UTC+1 időpontban ohad a következőt
    írta:
On Thu, Dec 5, 2013 at 5:38 PM, <csaba...@shiwaforce.com >     <javascript:>> wrote:

    Hi All,

    I've done a successfull installation of Foreman / Proxy /
    Puppetmaster, but I've made a mistake. I didn't configured the
    Organization enabled, and run with that settings. When I
    realized, I've edited the /etc/foreman/settings.yaml file to
    :organizations_enabled: true, and restarted the foreman service
    - but there wasn't any changes: I still cannot see it in the web
    interface, only locations. 

    After that, I've added Hammer és Hammer for Forman, and try to
    done it from CLI - but the server responded with the following: 

    root@puppet:/etc/foreman# hammer organization list
    The server does not support such operation.

    My final thought was to run the foreman-installer again, with
    proper config, but the results are the same - still cannot add,
    or edit, or view any Organizations related informations. 

    Any idea? 

can you paste your config file? maybe a typo?

Ohad

    Thank you in advance, 

    Regards,
    Csaba

    -- 
    You received this message because you are subscribed to the
    Google Groups "Foreman users" group.
    To unsubscribe from this group and stop receiving emails from
    it, send an email to foreman-user...@googlegroups.com <javascript:>.
    To post to this group, send email to forema...@googlegroups.com
    <javascript:>.
    Visit this group at http://groups.google.com/group/foreman-users
    <http://groups.google.com/group/foreman-users>.
    For more options, visit https://groups.google.com/groups/opt_out
    <https://groups.google.com/groups/opt_out>.


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks, it has solved the Organization problem, but generated an another
one ( :-)) - see log end of message, after apache2 restart, I've restarted
foreman too. I had these errors. As I see, there is 2 problem, the first
one is the deprecation notice settings, but I cannot find Production.rb
just a production.rb /usr/share/foreman/config/enviroments. Is it okay, if
I rename these files to Uppercase? Current file list in that direcotry

root@puppet:/usr/share/foreman/config/environments# ls -l
total 12
-rw-r–r-- 1 foreman foreman 1375 Nov 11 12:25 development.rb
-rw-r–r-- 1 foreman foreman 3911 Nov 11 12:25 production.rb
-rw-r–r-- 1 foreman foreman 2028 Nov 11 12:25 test.rb

My enviroments ar Production, Development and Test. If

The second one is database adapter specifications, where can I specify the
adapter?

Regards,
Csaba

root@puppet:/etc/foreman# /etc/init.d/foreman restart
[…] Restarting : foremanYou did not specify how you would like Rails to
report deprecation notices for your Production environment, please set
config.active_support.deprecation to :log, :notify or :stderr at
config/environments/Production.rb
/usr/share/foreman/vendor/ruby/1.9.1/gems/activerecord-3.2.15/lib/active_record/connection_adapters/abstract/connection_specification.rb:47:in
resolve_hash_connection&#39;: database configuration does not specify adapter (ActiveRecord::AdapterNotSpecified) from /usr/share/foreman/vendor/ruby/1.9.1/gems/activerecord-3.2.15/lib/active_record/connection_adapters/abstract/connection_specification.rb:41:inresolve_string_connection'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/activerecord-3.2.15/lib/active_record/connection_adapters/abstract/connection_specification.rb:25:in
spec&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/activerecord-3.2.15/lib/active_record/connection_adapters/abstract/connection_specification.rb:130:inestablish_connection'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/activerecord-3.2.15/lib/active_record/railtie.rb:88:in
block (2 levels) in &lt;class:Railtie&gt;&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/lazy_load_hooks.rb:36:ininstance_eval'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/lazy_load_hooks.rb:36:in
execute_hook&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/lazy_load_hooks.rb:26:inblock in on_load'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/lazy_load_hooks.rb:25:in
each&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/lazy_load_hooks.rb:25:inon_load'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/activerecord-3.2.15/lib/active_record/railtie.rb:80:in
block in &lt;class:Railtie&gt;&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/initializable.rb:30:ininstance_exec'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/initializable.rb:30:in
run&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/initializable.rb:55:inblock in run_initializers'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/initializable.rb:54:in
each&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/initializable.rb:54:inrun_initializers'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/application.rb:136:in
initialize!&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/railtie/configurable.rb:30:inmethod_missing'
from /usr/share/foreman/config/environment.rb:5:in &lt;top (required)&gt;&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/dependencies.rb:251:inrequire'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/dependencies.rb:251:in
block in require&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/dependencies.rb:236:inload_dependency'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/dependencies.rb:251:in
require&#39; from /usr/share/foreman/config.ru:3:inblock in <main>'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:51:in
instance_eval&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:51:ininitialize'
from /usr/share/foreman/config.ru:in new&#39; from /usr/share/foreman/config.ru:in<main>'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:40:in
eval&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:40:inparse_file'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/server.rb:200:in
app&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/commands/server.rb:46:inapp'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/server.rb:304:in
wrapped_app&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/server.rb:254:instart'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/commands/server.rb:70:in
start&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/commands.rb:55:inblock in <top (required)>'
from
/usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/commands.rb:50:in
tap&#39; from /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/commands.rb:50:in<top (required)>'
from script/rails:6:in require&#39; from script/rails:6:in<main>'
failed!

  1. december 6., péntek 10:12:19 UTC+1 időpontban Dominic Cleal a
    következőt írta:
··· > > Looks ok - can you try restarting httpd (Red Hat) or apache2 (Debian, > Ubuntu)? > > -- > Dominic Cleal > Red Hat Engineering > > On 06/12/13 09:05, csaba...@shiwaforce.com wrote: > > Hi Ohad, > > > > thank you for your response, see puppet.conf, settings.yaml attached. > > > > regards, > > Csaba > > > > > > > > > > 2013. december 5., csütörtök 17:01:39 UTC+1 időpontban ohad a következőt > > írta: > > > > > > > > > > On Thu, Dec 5, 2013 at 5:38 PM, > > wrote: > > > > Hi All, > > > > I've done a successfull installation of Foreman / Proxy / > > Puppetmaster, but I've made a mistake. I didn't configured the > > Organization enabled, and run with that settings. When I > > realized, I've edited the /etc/foreman/settings.yaml file to > > :organizations_enabled: true, and restarted the foreman service > > - but there wasn't any changes: I still cannot see it in the web > > interface, only locations. > > > > After that, I've added Hammer és Hammer for Forman, and try to > > done it from CLI - but the server responded with the following: > > > > root@puppet:/etc/foreman# hammer organization list > > The server does not support such operation. > > > > My final thought was to run the foreman-installer again, with > > proper config, but the results are the same - still cannot add, > > or edit, or view any Organizations related informations. > > > > Any idea? > > > > can you paste your config file? maybe a typo? > > > > Ohad > > > > Thank you in advance, > > > > Regards, > > Csaba > > > > -- > > You received this message because you are subscribed to the > > Google Groups "Foreman users" group. > > To unsubscribe from this group and stop receiving emails from > > it, send an email to foreman-user...@googlegroups.com. > > To post to this group, send email to forema...@googlegroups.com > > . > > Visit this group at http://groups.google.com/group/foreman-users > > . > > For more options, visit https://groups.google.com/groups/opt_out > > . > > > > > > -- > > You received this message because you are subscribed to the Google > > Groups "Foreman users" group. > > To unsubscribe from this group and stop receiving emails from it, send > > an email to foreman-user...@googlegroups.com . > > To post to this group, send email to forema...@googlegroups.com. > > > Visit this group at http://groups.google.com/group/foreman-users. > > For more options, visit https://groups.google.com/groups/opt_out. > >

Hi All,

All the problems has been solved. The renaming of the Puppet environment
files is fixed the first error, and export RAILS_ENV=production has fixed
the second error message (after succesfull run of bundle install, which has
installed mysql2, and other gems).

Thanks,
Csaba

  1. december 6., péntek 10:28:50 UTC+1 időpontban csaba...@shiwaforce.com
    a következőt írta:
··· > > Thanks, it has solved the Organization problem, but generated an another > one ( :-)) - see log end of message, after apache2 restart, I've restarted > foreman too. I had these errors. As I see, there is 2 problem, the first > one is the deprecation notice settings, but I cannot find Production.rb > just a production.rb /usr/share/foreman/config/enviroments. Is it okay, if > I rename these files to Uppercase? Current file list in that direcotry > > root@puppet:/usr/share/foreman/config/environments# ls -l > total 12 > -rw-r--r-- 1 foreman foreman 1375 Nov 11 12:25 development.rb > -rw-r--r-- 1 foreman foreman 3911 Nov 11 12:25 production.rb > -rw-r--r-- 1 foreman foreman 2028 Nov 11 12:25 test.rb > > My enviroments ar Production, Development and Test. If > > The second one is database adapter specifications, where can I specify the > adapter? > > Regards, > Csaba > > root@puppet:/etc/foreman# /etc/init.d/foreman restart > [....] Restarting : foremanYou did not specify how you would like Rails to > report deprecation notices for your Production environment, please set > config.active_support.deprecation to :log, :notify or :stderr at > config/environments/Production.rb > /usr/share/foreman/vendor/ruby/1.9.1/gems/activerecord-3.2.15/lib/active_record/connection_adapters/abstract/connection_specification.rb:47:in > `resolve_hash_connection': database configuration does not specify adapter > (ActiveRecord::AdapterNotSpecified) > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activerecord-3.2.15/lib/active_record/connection_adapters/abstract/connection_specification.rb:41:in > `resolve_string_connection' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activerecord-3.2.15/lib/active_record/connection_adapters/abstract/connection_specification.rb:25:in > `spec' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activerecord-3.2.15/lib/active_record/connection_adapters/abstract/connection_specification.rb:130:in > `establish_connection' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activerecord-3.2.15/lib/active_record/railtie.rb:88:in > `block (2 levels) in ' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/lazy_load_hooks.rb:36:in > `instance_eval' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/lazy_load_hooks.rb:36:in > `execute_hook' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/lazy_load_hooks.rb:26:in > `block in on_load' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/lazy_load_hooks.rb:25:in > `each' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/lazy_load_hooks.rb:25:in > `on_load' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activerecord-3.2.15/lib/active_record/railtie.rb:80:in > `block in ' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/initializable.rb:30:in > `instance_exec' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/initializable.rb:30:in > `run' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/initializable.rb:55:in > `block in run_initializers' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/initializable.rb:54:in > `each' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/initializable.rb:54:in > `run_initializers' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/application.rb:136:in > `initialize!' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/railtie/configurable.rb:30:in > `method_missing' > from /usr/share/foreman/config/environment.rb:5:in ` (required)>' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/dependencies.rb:251:in > `require' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/dependencies.rb:251:in > `block in require' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/dependencies.rb:236:in > `load_dependency' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/activesupport-3.2.15/lib/active_support/dependencies.rb:251:in > `require' > from /usr/share/foreman/config.ru:3:in `block in ' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:51:in > `instance_eval' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:51:in > `initialize' > from /usr/share/foreman/config.ru:in `new' > from /usr/share/foreman/config.ru:in `' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:40:in > `eval' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:40:in > `parse_file' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/server.rb:200:in > `app' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/commands/server.rb:46:in > `app' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/server.rb:304:in > `wrapped_app' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/rack-1.4.5/lib/rack/server.rb:254:in > `start' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/commands/server.rb:70:in > `start' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/commands.rb:55:in > `block in ' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/commands.rb:50:in > `tap' > from > /usr/share/foreman/vendor/ruby/1.9.1/gems/railties-3.2.15/lib/rails/commands.rb:50:in > `' > from script/rails:6:in `require' > from script/rails:6:in `' > failed! > > > 2013. december 6., péntek 10:12:19 UTC+1 időpontban Dominic Cleal a > következőt írta: >> >> Looks ok - can you try restarting httpd (Red Hat) or apache2 (Debian, >> Ubuntu)? >> >> -- >> Dominic Cleal >> Red Hat Engineering >> >> On 06/12/13 09:05, csaba...@shiwaforce.com wrote: >> > Hi Ohad, >> > >> > thank you for your response, see puppet.conf, settings.yaml attached. >> > >> > regards, >> > Csaba >> > >> > >> > >> > >> > 2013. december 5., csütörtök 17:01:39 UTC+1 időpontban ohad a >> következőt >> > írta: >> > >> > >> > >> > >> > On Thu, Dec 5, 2013 at 5:38 PM, > > > wrote: >> > >> > Hi All, >> > >> > I've done a successfull installation of Foreman / Proxy / >> > Puppetmaster, but I've made a mistake. I didn't configured the >> > Organization enabled, and run with that settings. When I >> > realized, I've edited the /etc/foreman/settings.yaml file to >> > :organizations_enabled: true, and restarted the foreman service >> > - but there wasn't any changes: I still cannot see it in the >> web >> > interface, only locations. >> > >> > After that, I've added Hammer és Hammer for Forman, and try to >> > done it from CLI - but the server responded with the following: >> > >> > root@puppet:/etc/foreman# hammer organization list >> > The server does not support such operation. >> > >> > My final thought was to run the foreman-installer again, with >> > proper config, but the results are the same - still cannot add, >> > or edit, or view any Organizations related informations. >> > >> > Any idea? >> > >> > can you paste your config file? maybe a typo? >> > >> > Ohad >> > >> > Thank you in advance, >> > >> > Regards, >> > Csaba >> > >> > -- >> > You received this message because you are subscribed to the >> > Google Groups "Foreman users" group. >> > To unsubscribe from this group and stop receiving emails from >> > it, send an email to foreman-user...@googlegroups.com. >> > To post to this group, send email to forema...@googlegroups.com >> > . >> > Visit this group at >> http://groups.google.com/group/foreman-users >> > . >> > For more options, visit >> https://groups.google.com/groups/opt_out >> > . >> > >> > >> > -- >> > You received this message because you are subscribed to the Google >> > Groups "Foreman users" group. >> > To unsubscribe from this group and stop receiving emails from it, send >> > an email to foreman-user...@googlegroups.com. >> > To post to this group, send email to forema...@googlegroups.com. >> > Visit this group at http://groups.google.com/group/foreman-users. >> > For more options, visit https://groups.google.com/groups/opt_out. >> >>