Can't change Location and Organization fields when trying to provision a discovered host

I actually have two issues:
The first is described in the subject, both option are set to the default
set in "settings" => "discovered" but they are grayed out and fixed.
The second issue, which makes the first one much worse, is the fact that
when I choose any hostgroup, both Location and Organization fields change
to what appears to be the first item in their respective list(in
alphabetical order).

All hostgroups are assigned to all locations/organizations, and creating a
new host works without issues, has anyone here encountered these issues?

I'm running Foreman 1.6.1 with discovery 1.4.0.rc4

The first issue in known - when you provision a discovered host you are in
'edit' mode of that host and you can't change location/organization while
editing a host.
What you can do is before provisioning on the discovered hosts page select
the hosts you want (with the checkbox) and a "Select Action" button will
appear
you can select "assign location/organization" and select the
organization/location you want and then provision.

··· On Tue, Oct 28, 2014 at 12:20 PM, Oded Ben Ozer wrote:

I actually have two issues:
The first is described in the subject, both option are set to the default
set in “settings” => “discovered” but they are grayed out and fixed.
The second issue, which makes the first one much worse, is the fact that
when I choose any hostgroup, both Location and Organization fields change
to what appears to be the first item in their respective list(in
alphabetical order).

All hostgroups are assigned to all locations/organizations, and creating a
new host works without issues, has anyone here encountered these issues?

I’m running Foreman 1.6.1 with discovery 1.4.0.rc4


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.

Thanks, , but the location/organization are still being replaced after
selecting the hostgroup so i'm still stuck.

··· On Tuesday, October 28, 2014 2:47:51 PM UTC+2, Ori Rabin wrote: > > The first issue in known - when you provision a discovered host you are in > 'edit' mode of that host and you can't change location/organization while > editing a host. > What you can do is before provisioning on the discovered hosts page select > the hosts you want (with the checkbox) and a "Select Action" button will > appear > you can select "assign location/organization" and select the > organization/location you want and then provision. > > On Tue, Oct 28, 2014 at 12:20 PM, Oded Ben Ozer > wrote: > >> I actually have two issues: >> The first is described in the subject, both option are set to the default >> set in "settings" => "discovered" but they are grayed out and fixed. >> The second issue, which makes the first one much worse, is the fact that >> when I choose any hostgroup, both Location and Organization fields change >> to what appears to be the first item in their respective list(in >> alphabetical order). >> >> All hostgroups are assigned to all locations/organizations, and creating >> a new host works without issues, has anyone here encountered these issues? >> >> I'm running Foreman 1.6.1 with discovery 1.4.0.rc4 >> >> >> -- >> You received this message because you are subscribed to the Google Groups >> "Foreman users" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to foreman-user...@googlegroups.com . >> To post to this group, send email to forema...@googlegroups.com >> . >> Visit this group at http://groups.google.com/group/foreman-users. >> For more options, visit https://groups.google.com/d/optout. >> > >

I opened a bug for that: Bug #8148: Allow editing taxonomy on Provision Host form - Discovery - Foreman
workaround for now - change context and pick a location\organization
if you are not using any location\organization in the context but a
specific one they don't change when you pick a hostgroup

··· On Tue, Oct 28, 2014 at 5:15 PM, Oded Ben Ozer wrote:

Thanks, , but the location/organization are still being replaced after
selecting the hostgroup so i’m still stuck.

On Tuesday, October 28, 2014 2:47:51 PM UTC+2, Ori Rabin wrote:

The first issue in known - when you provision a discovered host you are
in ‘edit’ mode of that host and you can’t change location/organization
while editing a host.
What you can do is before provisioning on the discovered hosts page
select the hosts you want (with the checkbox) and a “Select Action” button
will appear
you can select “assign location/organization” and select the
organization/location you want and then provision.

On Tue, Oct 28, 2014 at 12:20 PM, Oded Ben Ozer ode...@taboola.com >> wrote:

I actually have two issues:
The first is described in the subject, both option are set to the
default set in “settings” => “discovered” but they are grayed out and fixed.
The second issue, which makes the first one much worse, is the fact that
when I choose any hostgroup, both Location and Organization fields change
to what appears to be the first item in their respective list(in
alphabetical order).

All hostgroups are assigned to all locations/organizations, and creating
a new host works without issues, has anyone here encountered these issues?

I’m running Foreman 1.6.1 with discovery 1.4.0.rc4


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to foreman-user...@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.

Thanks, the workaround works for me, also "watching" the bug

··· On Wed, Oct 29, 2014 at 10:25 AM, Ori Rabin wrote:

I opened a bug for that: Bug #8148: Allow editing taxonomy on Provision Host form - Discovery - Foreman
workaround for now - change context and pick a location\organization
if you are not using any location\organization in the context but a
specific one they don’t change when you pick a hostgroup

On Tue, Oct 28, 2014 at 5:15 PM, Oded Ben Ozer oded.b@taboola.com wrote:

Thanks, , but the location/organization are still being replaced after
selecting the hostgroup so i’m still stuck.

On Tuesday, October 28, 2014 2:47:51 PM UTC+2, Ori Rabin wrote:

The first issue in known - when you provision a discovered host you are
in ‘edit’ mode of that host and you can’t change location/organization
while editing a host.
What you can do is before provisioning on the discovered hosts page
select the hosts you want (with the checkbox) and a “Select Action” button
will appear
you can select “assign location/organization” and select the
organization/location you want and then provision.

On Tue, Oct 28, 2014 at 12:20 PM, Oded Ben Ozer ode...@taboola.com >>> wrote:

I actually have two issues:
The first is described in the subject, both option are set to the
default set in “settings” => “discovered” but they are grayed out and fixed.
The second issue, which makes the first one much worse, is the fact
that when I choose any hostgroup, both Location and Organization fields
change to what appears to be the first item in their respective list(in
alphabetical order).

All hostgroups are assigned to all locations/organizations, and
creating a new host works without issues, has anyone here encountered these
issues?

I’m running Foreman 1.6.1 with discovery 1.4.0.rc4


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to foreman-user...@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “Foreman users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/foreman-users/ipqYid64IM0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.