Can't find entry point 'foreman_remote_execution' in webpack manifest after upgrading from 2.1.2 to 2.2

I’ve tried to upgrade Foreman from version 2.1 to 2.2, but after the upgrade I’m unable to view the jobs pages. When I try to browse to any of the jobs, it only shows a 500 page: " Oops, we’re sorry but something went wrong Can’t find entry point ‘foreman_remote_execution’ in webpack manifest"

I’m running foreman and the proxies on Debian 10, with backports enabled.

Here is the output from foreman-rake errors:fetch_log:
foreman-rake errors:fetch_log request_id=c1dccc2d
2020-11-09T14:16:26 [I|app|c1dccc2d] Started GET “/job_invocations/298” for at 2020-11-09 14:16:26 +0100
2020-11-09T14:16:26 [I|app|c1dccc2d] Processing by JobInvocationsController#show as HTML
2020-11-09T14:16:26 [I|app|c1dccc2d] Parameters: {“id”=>“298”}
2020-11-09T14:16:26 [I|app|c1dccc2d] Rendering vendor/ruby/2.5.0/gems/foreman_remote_execution-4.1.0/app/views/job_invocations/show.html.erb within layouts/application
2020-11-09T14:16:26 [I|app|c1dccc2d] Rendered vendor/ruby/2.5.0/gems/foreman_remote_execution-4.1.0/app/views/job_invocations/show.html.erb within layouts/application (Duration: 1.6ms | Allocations: 1006)
2020-11-09T14:16:26 [W|app|c1dccc2d] Can’t find entry point ‘foreman_remote_execution’ in webpack manifest
2020-11-09T14:16:26 [I|app|c1dccc2d] Backtrace for ‘Can’t find entry point ‘foreman_remote_execution’ in webpack manifest’ error (ActionView::Template::Error): Can’t find entry point ‘foreman_remote_execution’ in webpack manifest
2020-11-09T14:16:26 [I|app|c1dccc2d] Rendering common/500.html.erb within layouts/application
2020-11-09T14:16:26 [I|app|c1dccc2d] Rendered common/500.html.erb within layouts/application (Duration: 1.6ms | Allocations: 1017)
2020-11-09T14:16:26 [I|app|c1dccc2d] Rendered layouts/_application_content.html.erb (Duration: 3.2ms | Allocations: 5445)
2020-11-09T14:16:26 [I|app|c1dccc2d] Rendering layouts/base.html.erb
2020-11-09T14:16:26 [I|app|c1dccc2d] Rendered layouts/base.html.erb (Duration: 3.5ms | Allocations: 6426)
2020-11-09T14:16:26 [I|app|c1dccc2d] Completed 500 Internal Server Error in 39ms (Views: 13.0ms | ActiveRecord: 6.5ms | Allocations: 29129)

Foreman version: 2.2.0
 - foreman-tasks 3.0.1
 - foreman_remote_execution 4.1.0
 - puppetdb_foreman 5.0.0


thanks for reporting this! I couldn’t quickly reproduce this on a fresh 2.2 machine, so going to spin up a 2.1 and upgrade it to 2.2 afterwards. Just wanted to let you know we’re on it :slight_smile:


Okay, I can reproduce the issue on an upgraded system, but only if I don’t restart any services after the upgrade.

So systemctl restart foreman apache2 fixed it for me.

Do I assume correctly, that the upgrade you did was just editing /etc/apt/sources.list.d/deb_theforeman_org.list and running apt update && apt upgrade? Not re-running the installer or anything after that?

There is nothing wrong with that approach right now, although we want to deprecate the support for it in the future.

1 Like

FWIW, I think the technical issue is that the Foreman package is upgraded before the Remote Execution plugin and thus the restart that’s triggered by the Foreman package is still loading the old REX plugin, which doesn’t work properly in the new Foreman. The installation of the Plugin should trigger the restart too.

CC @ehelms


Thanks for your response. I’m using the puppet module to manage our foreman installation (yes, chicken-egg…). But I think that is basically the same as changing sources.list and doing the apt dance. I’m pretty sure I tried restarting apache2 and foreman, but who knows. I’ll give it another try anyway and keep you posted.


I just performed the upgrade manually, as described in the manual. That resolved the issue indeed. Thanks for the help!

Regards, Martijn

1 Like

I would have expected Puppet to restart services after the installation, but who knows.

Great to hear that it works now!

Service restarts work based on triggers. If you run yum update and there isn’t anything to do in the installer (no DB migrate, no other steps) it’ll think it’s already in the correct state and no service update will happen.