Change foreman url

We are trying to install foreman 3.3 in a server and we want it available at:

We are trying with the parameter --foreman-foreman-url at the installer but once you log to foreman it redirects to https://HOSTNAME/users/login and forgets the “/app/foreman” part of the url.

Can you help us with this issue?


1 Like

I wouldn’t recommend to run Foreman in subfolder, see the post RFC: Stop attempting to allow running foreman under a sub-folder in 3.0.

Hi, thanks for the link.

We want to put our foreman server behind a gateway (nginx server). This nginx server is the frontend from several web services and we want foreman to be one more.

So, is there a way to address https://domain/app/foreman to https://foreman-server/?

When we try it, foreman changes the url from https://domain/app/foreman to https://domain/users/login, looses the /app/foreman part and the nginx server doesn’t know how to redirect it.

We have tried changing settings like foreman url or proxy but it doesn’t work.

If we access without the nginx server to https://foreman-server everything goes fine.