Clients not updating due to certificate error [Errno 14] curl#60 - “Peer’s certificate issuer has been marked as not trusted by the user.”

Hi Marko,

Did this start failing after some changes or is this on a new setup?

No changes made to the system we had some nodes that hadn’t updated in awhile and thus when we tried to update them this was the error we received.

What’s the version of the foreman/katello server? Also, are there other hosts that can get content?

This currently is specific to Centos7.9 clients, and version is 3.31

I am not sure why the certs would work for 8 vs 7… @wbclark Do you know what might be causing this?

Is this for all Centos7 clients? Could you try re-registering a client and see if that helps.

I’ve had to move on to other issues but it’s still present as an open issue. I can try re-registering but what about removing client all together. I’m fighting through aritcles on how to do this.

I tried a couple of systems that actually worked. I’m curious though is there something that needs to be done on the proxy. ALSO – How do your remove katello COMPLELTely from these clients.