Clients show "Reboot required" after reboot

We have a number of legacy Oracle Linux 7 clients that show “Reboot required” after update and reboot. It persists whether rebooted manually or by remote execution. This is new with foreman 1.23.0/katello 3.13.0. The problem does not exist with Oracle Linux 6 or CentOS 7.

Expected outcome:
Indication clears after reboot.

Foreman and Proxy versions:
Foreman 1.23.0 - Katello 3.13.0

Distribution and version:
Oracle Linux 7.7+

Other relevant data:

Hello @poulterer,

Could we have a screenshot of where “Reboot required” is popping up? This is a feature of katello-host-tools-tracer, do you have that installed on your hosts?

All of the depicted OL7 systems have been rebooted by remote execution and have no pending reboots. The system “mpl02-app01-mpl02.internal” has been rebooted, both manually and via remote execution, but still shows “Reboot required.”

Which version of katello-host-tools-tracer do you have installed? Did you rebuild it for OracleLinux? It’s supposed to install a cronjob to upload a tracer after reboot but perhaps that’s not happening or failing.

Yes, it is executing. All were installed from RPM have worked for three years. This failure to accurately reflect reboot status is a new occurrence.The versions are:


The same behavior occurred with 3.5.0-1.

Can you manually execute it and check its output?

Yes, it has been executed when rebooted, locally and remotely. No combination will change the status display. There is no output and exit code is 0.

I ran into a similar issue today

It turned out my default kernel was not the latest that was installed :expressionless:

Something was off in my provisioning process.

As soon as I booted into the correct kernel it was fixed.