Create host with host groups and compute profile (Vcenter), storage tab empty

Problem:
Hi, I upgraded to foreman 1.22 / Katello 4.12. When I create a new host with my host groups, the storage section is empty and I cannot add a storage device manually.
When I create the host manually (without the host group) it works as expected.

I tried to configure a new host group and a new compute profile, but the outcome is the same.

Expected outcome:
Storage devices configuration should be taken from the compute profile.

Foreman and Proxy versions:
Foreman 1.22

Foreman and Proxy plugin versions:

Other relevant data:
Centos 7.6 / Foreman Katello
Compute Profiles are connected with a VCenter 6.5 and a second VCenter with Version 6.0.

logs

I can reproduce this, thanks for reporting.
I will try to fix it and get back to you when I do.

Do you have the ansible plugin installed?

Ansible plugin ist active, thanks for your help

We are having the same issue, do we need the ansible plugin installed and active?

No, the issue is actually caused by ansible roles component mounting, so if you remove ansible plugin, the storage selection should appear :slight_smile:

how can I disable the ansible plugin? I tried:

 foreman-installer --no-enable-foreman-plugin-ansible --no-enable-foreman-proxy-plugin-ansible

but it still there.

I’ve run the same commands and the issue is still present…

foreman-installer --no-enable-foreman-plugin-ansible --no-enable-foreman-proxy-plugin-ansible

Still having an issue here on the 1.22, looking to upgrade to 1.22.1 to see if that fixes it. Even shoved in a reboot afterwards…

Sorry guys for keeping you waiting, I’ve been struggling to resolved it. It’s caused by nested form tags.

This is solved now and should be in next 1.23 release.

Here is the PR, which solves it: