Deprecation of legacy subscription management

There is no warning before Katello 4.5. I have only noticed it with 4.5 (see original post above).

Correct. As long as you don’t use SCA, you assign subscriptions (aka products) to content hosts and they get access to all repositories in the product. As you cannot set the default for repositories in products to disabled, a content host has all repositories of your custom products enabled by default. (Of course you can hide repositories with content views and you can use activation keys to set most repositories to disabled for new content hosts…)

Once SCA becomes mandatory, there are no subscriptions anymore. Content hosts connected to your server have access to all repositories (visible in the assigned content view), which again are enabled by default for all repositories in all your custom products.

Still, it needs preparation because otherwise your client hosts all of a sudden will have tons of repositories visible and enabled after the change…

On Katello 4.5.1.
Simple Content Access is not really something I had to select when installing and am not a Red Hat customer and have not imported a manifest and looking in the documentation it says,

Simple Content Access

Note: Currently this feature is only relevant for Red Hat customers who import subscription manifests, but will be available to all Katello users in a future version.

Looking in setttings:

So I assume I do not use SCA but I do not get a warning about it.
Maybe that is why I am a little confused about this topic :slight_smile:

I think you’ve discovered a bug, thanks!

The deprecation banner currently shows only if a manifest is imported. But now that SCA status is no longer coupled to the manifest, it should show regardless.

Filed Bug #35698: SCA deprecation banners don't show if manifest not imported - Katello - Foreman.

I am still a little confused. According to gvde the banner say:

This organization is not using Simple Content Access. Legacy subscription management is deprecated and will be removed in a future version.

So this tells me you can either use “Simple Content Access” or “Subscription management”.
“Simple Content Access” is only for Red Hat customers who import subscription manifests so not for me.
“Subscription management” will according to the banner be deprecated and I guess that is what I am using?
So since SCA is not for me and “Subscription management” will be removed in the future, what is left?

RedHat is deprecating subscription management and switching to SCA. That‘s why satellite/katello is, too.

You can use SCA. Just right know, there is the GUI option missing to activate it, unless you have imported a manifest. Once that bug mentioned has been solved, you‘ll have the option to use SCA. And at some point in the future, you‘ll have to use it, once subscription management has been removed…

If you upgrade to Katello 4.6 you will be able to turn SCA on or off without importing a manifest. It’s on the Organization edit screen.

just to add my experience to it:

  • enabled SCA
  • all 63 repos became active on all hosts (including el6+7+8+9 simultaniously)
  • as soon as you did an update vm switched to el9 glibc on el8 hosts, ssh stopped working on all hosts, you are esstially locked out and theres no way to rollback anymore

i feel “simple” content access does not live up its name

Yes. That is well known and discussed. See also [RFC] Making things easier when working with custom products & Simple Content Access (SCA)

I have still not taken the plunge to SCA, but seems when Katello 4.8.1 arrives and deployed is the time to do it I guess. :sunglasses:

Seen 4.8.1 arrive but nothing in release notes about actually solving the problem with all repos activated when going to SCA.

Alas, being a minor release 4.8.1 didn’t get anything added to the “Headline features” documentation section. This particular change is kind of special that way; we don’t usually add features in patch releases.

Rest assured, Fixes #36301 - Auto-create content overrides on SCA enable (#10528) · Katello/katello@6f25812 · GitHub is indeed in 4.8.1 - Commits · Katello/katello · GitHub

@lfu I think perhaps the 4.8.1 branch needs to have its updated?