Directory index forbidden by Options directive: /var/lib/foreman/public

I just installed the RPM: foreman-0.1.6-2 but I keep on getting error
message: Directory index forbidden by Options directive: /var/lib/
foreman/public (when running via passenger)

I have it running fine in my test environment which is running from
source, but I don't seem to be able to get it to run with the RPM. I
have all the requirements installed. I can run foreman via script/
server -e production --port 8080, but I can't run it via passenger.

OS=CentOS 5.5
RPM's:
httpd-2.2.3-43.el5.centos.3
rubygem-sqlite3-ruby-1.2.4-1.el5
rubygem-rake-0.8.7-2.el5

Gems:
daemon_controller (0.2.5)
fastthread (1.0.7)
file-tail (1.0.5)
mysql (2.8.1, 2.7)
passenger (2.2.11)
rack (1.0.1)
rake (0.8.7)
rubygems-update (1.3.7)
spruz (0.2.2)
sqlite3-ruby (1.2.4)

Any Ideas?

Thanks,

BTW: This is my /etc/httpd/conf.d/foreman.conf:

<VirtualHost x.x.x.x:80>
ServerName server.dev.domain.com.pem
ServerAlias foreman
DocumentRoot /var/lib/foreman/public

RailsAutoDetect On
AddDefaultCharset UTF-8

Grant access to puppet reports

Alias /report /var/lib/puppet/rrd/
<Directory /var/lib/puppet/rrd/>
PassengerEnabled off
Options Indexes
Order deny,allow
Allow from all
</Directory>
</VirtualHost>

<VirtualHost x.x.x.x:443>
ServerName Server.domain.com
ServerAlias foreman

RailsAutoDetect On
DocumentRoot /var/lib/foreman/public

Use puppet certi ficates for SSL

SSLEngine on
SSLCertificateFile /etc/puppet/ssl/certs/
server.dev.domain.com.pem
SSLCertificateKeyFile /etc/puppet/ssl/private_keys/
server.dev.domain.com.pem
SSLCertificateChainFile /etc/puppet/ssl/ca/ca_crt.pem
SSLCACertificateFile /etc/puppet/ssl/ca/ca_crt.pem
SSLCARevocationFile /etc/puppet/ssl/ca/ca_crl.pem
SSLVerifyClient optional
SSLVerifyDepth 3
SSLOptions +StdEnvVars

</VirtualHost>

··· On Dec 10, 1:01 pm, CraftyTech wrote: > I just installed the RPM: foreman-0.1.6-2 but I keep on getting error > message: Directory index forbidden by Options directive: /var/lib/ > foreman/public (when running via passenger) > > I have it running fine in my test environment which is running from > source, but I don't seem to be able to get it to run with the RPM. I > have all the requirements installed. I can run foreman via script/ > server -e production --port 8080, but I can't run it via passenger. > > OS=CentOS 5.5 > RPM's: > httpd-2.2.3-43.el5.centos.3 > rubygem-sqlite3-ruby-1.2.4-1.el5 > rubygem-rake-0.8.7-2.el5 > > Gems: > daemon_controller (0.2.5) > fastthread (1.0.7) > file-tail (1.0.5) > mysql (2.8.1, 2.7) > passenger (2.2.11) > rack (1.0.1) > rake (0.8.7) > rubygems-update (1.3.7) > spruz (0.2.2) > sqlite3-ruby (1.2.4) > > Any Ideas? > > Thanks,

double check that ~foreman/config/environment.rb is owner by foreman user
and not root.

it sounds like passenger doesnt start up correctly… probably more info at
apache logs.

Ohad

··· On Fri, Dec 10, 2010 at 8:08 PM, CraftyTech wrote:

BTW: This is my /etc/httpd/conf.d/foreman.conf:

ServerName server.dev.domain.com.pem ServerAlias foreman DocumentRoot /var/lib/foreman/public

RailsAutoDetect On
AddDefaultCharset UTF-8

Grant access to puppet reports

Alias /report /var/lib/puppet/rrd/
<Directory /var/lib/puppet/rrd/>
PassengerEnabled off
Options Indexes
Order deny,allow
Allow from all

ServerName Server.domain.com ServerAlias foreman

RailsAutoDetect On
DocumentRoot /var/lib/foreman/public

Use puppet certi ficates for SSL

SSLEngine on
SSLCertificateFile /etc/puppet/ssl/certs/
server.dev.domain.com.pem
SSLCertificateKeyFile /etc/puppet/ssl/private_keys/
server.dev.domain.com.pem
SSLCertificateChainFile /etc/puppet/ssl/ca/ca_crt.pem
SSLCACertificateFile /etc/puppet/ssl/ca/ca_crt.pem
SSLCARevocationFile /etc/puppet/ssl/ca/ca_crl.pem
SSLVerifyClient optional
SSLVerifyDepth 3
SSLOptions +StdEnvVars

On Dec 10, 1:01 pm, CraftyTech hmmed...@gmail.com wrote:

I just installed the RPM: foreman-0.1.6-2 but I keep on getting error
message: Directory index forbidden by Options directive: /var/lib/
foreman/public (when running via passenger)

I have it running fine in my test environment which is running from
source, but I don’t seem to be able to get it to run with the RPM. I
have all the requirements installed. I can run foreman via script/
server -e production --port 8080, but I can’t run it via passenger.

OS=CentOS 5.5
RPM’s:
httpd-2.2.3-43.el5.centos.3
rubygem-sqlite3-ruby-1.2.4-1.el5
rubygem-rake-0.8.7-2.el5

Gems:
daemon_controller (0.2.5)
fastthread (1.0.7)
file-tail (1.0.5)
mysql (2.8.1, 2.7)
passenger (2.2.11)
rack (1.0.1)
rake (0.8.7)
rubygems-update (1.3.7)
spruz (0.2.2)
sqlite3-ruby (1.2.4)

Any Ideas?

Thanks,


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To post to this group, send email to foreman-users@googlegroups.com.
To unsubscribe from this group, send email to
foreman-users+unsubscribe@googlegroups.comforeman-users%2Bunsubscribe@googlegroups.com
.
For more options, visit this group at
http://groups.google.com/group/foreman-users?hl=en.

I'm checking /etc/httpd/logs/error_log, and this is what I get:

[Fri Dec 10 14:05:47 2010] [notice] suEXEC mechanism enabled
(wrapper: /usr/sbin/suexec)
[Fri Dec 10 14:05:47 2010] [notice] Digest: generating secret for
digest authentication …
[Fri Dec 10 14:05:47 2010] [notice] Digest: done
[Fri Dec 10 14:05:47 2010] [notice] Apache/2.2.3 (CentOS) configured
– resuming normal operations
[Fri Dec 10 14:05:52 2010] [error] [client xx.xx.xx.xx] Directory
index forbidden by Options directive: /var/lib/foreman/public/
[Fri Dec 10 14:05:53 2010] [error] [client xx.xx.xx.xx] Directory
index forbidden by Options directive: /var/lib/foreman/public/
[Fri Dec 10 14:05:54 2010] [error] [client xx.xx.xx.xx] Directory
index forbidden by Options directive: /var/lib/foreman/public/
[Fri Dec 10 14:05:54 2010] [error] [client xx.xx.xx.xx] Directory
index forbidden by Options directive: /var/lib/foreman/public/
[Fri Dec 10 14:05:58 2010] [error] [client xx.xx.xx.xx] Directory
index forbidden by Options directive: /var/lib/foreman/public/
[Fri Dec 10 14:06:18 2010] [error] [client xx.xx.xx.xx] Directory
index forbidden by Options directive: /var/lib/foreman/public/

/usr/share/foreman/config/environment.rb is owned by Foreman and the
permission is 755…

Thanks,

··· On Dec 10, 1:46 pm, Ohad Levy wrote: > double check that ~foreman/config/environment.rb is owner by foreman user > and not root. > > it sounds like passenger doesnt start up correctly... probably more info at > apache logs. > > Ohad > > > > > > > > On Fri, Dec 10, 2010 at 8:08 PM, CraftyTech wrote: > > BTW: This is my /etc/httpd/conf.d/foreman.conf: > > > > > ServerName server.dev.domain.com.pem > > ServerAlias foreman > > DocumentRoot /var/lib/foreman/public > > > RailsAutoDetect On > > AddDefaultCharset UTF-8 > > > # Grant access to puppet reports > > Alias /report /var/lib/puppet/rrd/ > > > > PassengerEnabled off > > Options Indexes > > Order deny,allow > > Allow from all > > > > > > > > > ServerName Server.domain.com > > ServerAlias foreman > > > RailsAutoDetect On > > DocumentRoot /var/lib/foreman/public > > > # Use puppet certi ficates for SSL > > SSLEngine on > > SSLCertificateFile /etc/puppet/ssl/certs/ > > server.dev.domain.com.pem > > SSLCertificateKeyFile /etc/puppet/ssl/private_keys/ > > server.dev.domain.com.pem > > SSLCertificateChainFile /etc/puppet/ssl/ca/ca_crt.pem > > SSLCACertificateFile /etc/puppet/ssl/ca/ca_crt.pem > > SSLCARevocationFile /etc/puppet/ssl/ca/ca_crl.pem > > SSLVerifyClient optional > > SSLVerifyDepth 3 > > SSLOptions +StdEnvVars > > > > > > On Dec 10, 1:01 pm, CraftyTech wrote: > > > I just installed the RPM: foreman-0.1.6-2 but I keep on getting error > > > message: Directory index forbidden by Options directive: /var/lib/ > > > foreman/public (when running via passenger) > > > > I have it running fine in my test environment which is running from > > > source, but I don't seem to be able to get it to run with the RPM. I > > > have all the requirements installed. I can run foreman via script/ > > > server -e production --port 8080, but I can't run it via passenger. > > > > OS=CentOS 5.5 > > > RPM's: > > > httpd-2.2.3-43.el5.centos.3 > > > rubygem-sqlite3-ruby-1.2.4-1.el5 > > > rubygem-rake-0.8.7-2.el5 > > > > Gems: > > > daemon_controller (0.2.5) > > > fastthread (1.0.7) > > > file-tail (1.0.5) > > > mysql (2.8.1, 2.7) > > > passenger (2.2.11) > > > rack (1.0.1) > > > rake (0.8.7) > > > rubygems-update (1.3.7) > > > spruz (0.2.2) > > > sqlite3-ruby (1.2.4) > > > > Any Ideas? > > > > Thanks, > > > -- > > You received this message because you are subscribed to the Google Groups > > "Foreman users" group. > > To post to this group, send email to foreman-users@googlegroups.com. > > To unsubscribe from this group, send email to > > foreman-users+unsubscribe@googlegroups.com > > . > > For more options, visit this group at > >http://groups.google.com/group/foreman-users?hl=en.

Also, puppet works fine under the same server and it's running under
passenger. Somehow, the RPM version of foreman under passenger is a
bit of an issue… Somehow the source version works fine provided the
same configs…

··· On Dec 10, 2:11 pm, CraftyTech wrote: > I'm checking /etc/httpd/logs/error_log, and this is what I get: > > [Fri Dec 10 14:05:47 2010] [notice] suEXEC mechanism enabled > (wrapper: /usr/sbin/suexec) > [Fri Dec 10 14:05:47 2010] [notice] Digest: generating secret for > digest authentication ... > [Fri Dec 10 14:05:47 2010] [notice] Digest: done > [Fri Dec 10 14:05:47 2010] [notice] Apache/2.2.3 (CentOS) configured > -- resuming normal operations > [Fri Dec 10 14:05:52 2010] [error] [client xx.xx.xx.xx] Directory > index forbidden by Options directive: /var/lib/foreman/public/ > [Fri Dec 10 14:05:53 2010] [error] [client xx.xx.xx.xx] Directory > index forbidden by Options directive: /var/lib/foreman/public/ > [Fri Dec 10 14:05:54 2010] [error] [client xx.xx.xx.xx] Directory > index forbidden by Options directive: /var/lib/foreman/public/ > [Fri Dec 10 14:05:54 2010] [error] [client xx.xx.xx.xx] Directory > index forbidden by Options directive: /var/lib/foreman/public/ > [Fri Dec 10 14:05:58 2010] [error] [client xx.xx.xx.xx] Directory > index forbidden by Options directive: /var/lib/foreman/public/ > [Fri Dec 10 14:06:18 2010] [error] [client xx.xx.xx.xx] Directory > index forbidden by Options directive: /var/lib/foreman/public/ > > /usr/share/foreman/config/environment.rb is owned by Foreman and the > permission is 755.... > > Thanks, > > On Dec 10, 1:46 pm, Ohad Levy wrote: > > > > > > > > > double check that ~foreman/config/environment.rb is owner by foreman user > > and not root. > > > it sounds like passenger doesnt start up correctly... probably more info at > > apache logs. > > > Ohad > > > On Fri, Dec 10, 2010 at 8:08 PM, CraftyTech wrote: > > > BTW: This is my /etc/httpd/conf.d/foreman.conf: > > > > > > > ServerName server.dev.domain.com.pem > > > ServerAlias foreman > > > DocumentRoot /var/lib/foreman/public > > > > RailsAutoDetect On > > > AddDefaultCharset UTF-8 > > > > # Grant access to puppet reports > > > Alias /report /var/lib/puppet/rrd/ > > > > > > PassengerEnabled off > > > Options Indexes > > > Order deny,allow > > > Allow from all > > > > > > > > > > > > > ServerName Server.domain.com > > > ServerAlias foreman > > > > RailsAutoDetect On > > > DocumentRoot /var/lib/foreman/public > > > > # Use puppet certi ficates for SSL > > > SSLEngine on > > > SSLCertificateFile /etc/puppet/ssl/certs/ > > > server.dev.domain.com.pem > > > SSLCertificateKeyFile /etc/puppet/ssl/private_keys/ > > > server.dev.domain.com.pem > > > SSLCertificateChainFile /etc/puppet/ssl/ca/ca_crt.pem > > > SSLCACertificateFile /etc/puppet/ssl/ca/ca_crt.pem > > > SSLCARevocationFile /etc/puppet/ssl/ca/ca_crl.pem > > > SSLVerifyClient optional > > > SSLVerifyDepth 3 > > > SSLOptions +StdEnvVars > > > > > > > > On Dec 10, 1:01 pm, CraftyTech wrote: > > > > I just installed the RPM: foreman-0.1.6-2 but I keep on getting error > > > > message: Directory index forbidden by Options directive: /var/lib/ > > > > foreman/public (when running via passenger) > > > > > I have it running fine in my test environment which is running from > > > > source, but I don't seem to be able to get it to run with the RPM. I > > > > have all the requirements installed. I can run foreman via script/ > > > > server -e production --port 8080, but I can't run it via passenger. > > > > > OS=CentOS 5.5 > > > > RPM's: > > > > httpd-2.2.3-43.el5.centos.3 > > > > rubygem-sqlite3-ruby-1.2.4-1.el5 > > > > rubygem-rake-0.8.7-2.el5 > > > > > Gems: > > > > daemon_controller (0.2.5) > > > > fastthread (1.0.7) > > > > file-tail (1.0.5) > > > > mysql (2.8.1, 2.7) > > > > passenger (2.2.11) > > > > rack (1.0.1) > > > > rake (0.8.7) > > > > rubygems-update (1.3.7) > > > > spruz (0.2.2) > > > > sqlite3-ruby (1.2.4) > > > > > Any Ideas? > > > > > Thanks, > > > > -- > > > You received this message because you are subscribed to the Google Groups > > > "Foreman users" group. > > > To post to this group, send email to foreman-users@googlegroups.com. > > > To unsubscribe from this group, send email to > > > foreman-users+unsubscribe@googlegroups.com > > > . > > > For more options, visit this group at > > >http://groups.google.com/group/foreman-users?hl=en.