Does Foreman 3.10 work on Ubuntu 24.04

Problem: - Having trouble deploying foreman on Ubuntu 24.04

Expected outcome: - Expected Foreman to be installed correctly

Foreman and Proxy versions: - 3.10

Foreman and Proxy plugin versions:

Distribution and version: - 3.10

Other relevant data: Ubuntu v 24.04
The following packages have unmet dependencies:
ruby-kafo : Depends: ruby-highline (< 3.0) but 3.0.1-1 is to be installed
E: Unable to correct problems, you have held broken packages.

I have tried to downgrade ruby-highline but it does not work, I have tried to upgrade it to the latest 3.0.1-1 but it does not work. I was unable to install ruby-kafo independently, Its my first time with Foreman installation and use so any pointers will help.

I have also done the ruby (apt install ruby) and ruby gems (apt install ruby-rubygems) install independently and tried the apt install foreman-installer but it fails with the same error.

Hi there,

as far as I know, you can install Foreman (without Katello) on top of EL 8, Debian 11 and Ubuntu 20.04, EL 9 is currently in the testing phase and will be supported in the next version.
Support for Debian 12 might come sooner or later, Ubuntu 22.04 might be ready for 3.11, and Ubuntu 24.04 was not in the scope yet, didn’t see any work on that yet.

Also on the client side there is no katello-host-tools compatible with 24.04 yet, but I’m sure that will show up in the next months :slight_smile:

(hope I got everything right, if not I’m sure someone might correct me ^^)

Tried both Foreman 3.10 and 3.11 on Ubuntu 24.04.
I am not beginner at system configuration but there was just too much hassle. Switched to CentOS Stream release 9 (EL 9 family) - still a lot of hassle but right now almost working. Deploymet to ProxMox 8.2.2 is my main concern currently. Got over the OpenSSL 3.x family unexpected EOF error just few hours ago.
Now trying to get the ProxMox compute resource itself actually to work for me.

For example - OpenSCAP does not work under Ubuntu as it is not supported. Even if you try to manually fix it it is … I will not even use acronym here.

Thanka guys I will ditch Ubuntu and try with Debian (bullseye) again, thanks again for your responses.

In 3.10 only Debian 11 and Ubuntu 20.04 are supported.
In 3.11 we add support for Ubuntu 22.04.
Debian 12 is blocked on Puppet not providing the puppetserver package for Debian 12.
Ubuntu 24.04 we’ve not started evaluating yet

1 Like