Domain created on install shows in CLI but is not present in UI


So I’ve got a “Host” (I’m putting quotes because I’m referring a host in the traditional sense rather than the foreman version of Host), dell server running Ubuntu 19.04 with KVM and libvirt installed.

I created a VM for foreman (rather than installing it on bare metal) using Ubuntu 18.04 and followed the quick start to install foreman.

The first issue I ran into was an error about ‘domain’ not being set, with a little bit of searching (and some help on the homelab discord) I discovered this was due to not having an fqdn in the host file (I had followed the step where it says to confirm I could ping the correct host but it doesn’t actually mention needing an fqdn in the quickstart).

I set the hostfile to <vm's IP> foreman.home.lan foreman and the installation was able to run fine. Now after connecting the “Host” to the foreman as a libvirt compute resource I’m trying to spin up a test Host (VM) and running into an issue.

When I try to create a Host inside the foreman it fails because the configured interface doesn’t have a domain set; when I look at the domains page in the UI no domains are listed but if I attempt to create home.lan it says it already exists.

When I run hammer domain list is shows the domain home.lan with the ID of 1 and if I attempt to delete it with hammer domain delete --id 1 I get home.lan is used by foreman.home.lan which while that doesn’t surprise me I can’t delete it the fact I can’t use it is a concern…

Expected outcome:

To see the domain home.lan in the UI and be able to assign subnets and hosts to it.

Foreman and Proxy versions:
foreman 1.22 + default, happy to update, unsure where to check atm…

Foreman and Proxy plugin versions:

see above?

Other relevant data:

will add if anyone suggests something I’m missing :smiley:

Wow… no edit huh? lol

lambchop on freenode asked if I had multiple organizations/locations and while I only have the defaults I was clicking around and hit any org.. and any loc... in the top drop downs and suddenly the domain shows up.

If I hit edit and look under the location and org for that domain, it shows the defaults. So weird. Is this a bug perhaps?

Solved (ish):

I went ahead and just hit submit and then tried reloading from the default org and default location and now the domain is showing up properly. I’m still debating if this is a UI bug of some sort and if I should open an issue for it but in the meantime I am unblocked.

Welcome to the Foreman community @IngCr3at1on!
This is Bug #27233: Mismatches for organization and location on production environment and domain - Foreman which will be fixed in the upcoming 1.23 release, which is expected to be released later this week.

P.S. Editing posts is disabled is because some people read these boards via e-mail, and they cannot see edits.


Thanks for the reply @tbrisker I’ve been running into other weird issues in trying to configure foreman (mostly it seems the presence of different plugins on install results in particularly different behavior; at this point I’ve broken foreman a couple times trying to get it configured and rather than messing with it have just rolled back snaps, resulting in my getting to see some rather strange behavior lol)…

do you think it would be better for me to just stop and wait for 1.23?

So after some extra fiddling I’ve come to the conclusion literally every issue I’ve encountered is related to this same bug. Most recently I’ve noticed I can’t import puppet classes (the button is missing) unless I switch to the any org and any location option; this is after fixing both the domain and environment to show up under the defaults…

It seems (to me at least) like I’m blocked until the next release from completing a fresh install. Will wait. Thanks again.