ERF12-4701 [ProxyAPI::ProxyException]: Unable to fetch Salt states list ([ProxyAPI::ProxyException]

ERF12-4701 [ProxyAPI::ProxyException]: Unable to fetch Salt states list ([ProxyAPI::ProxyException]: ERF12-7301 [ProxyAPI::ProxyException]: Unable to fetch Salt environments list ([RestClient::NotAcceptable]: 406 Not Acceptable) 代理服务器 https://client.localdomain:8443/salt/) 代理服务器 https://client.localdomain:8443/salt/

@zsy12 Which Foreman and Salt Plugin version are you using?

salt : 3004

What is the version of your foreman_salt and smart-proxy-salt plugins?


Can you also describe what you are trying to do when you get this error?

I click import from report error

Did you check whether your system is set up correctly?

1 Like

OK I check it now .

Why don’t I have this file? Did I install something less

The reactor file, you are referring to, becomes important in the new 14.1.0 Foreman Salt release which we are currently working on. It isn’t released by now, so it doesn’t matter for your 13.2.4 configuration.

In order to catch the Salt environments and states, the salt-api service must be configured and running on the Smart Proxy. Thereby, I’m referring to this part of the manual. Can you check whether the salt-api service is running on your Smart Proxy?


yes ! The salt-api is active (running)

The problem is still not resolve

I check log it reports error 2021-12-09 16:37:03,842 [rest_cherrypy :90 ][ERROR ][71476] Not starting ‘’. Options ‘ssl_crt’ and ‘ssl_key’ are required if SSL is not disabled.)



The cherrypy configuration looks fine. There are two more options we can try on this:
a) Remove the host: field completely or set it to
b) Disable ssl for debugging according to the Salt API Non-SSL fallback part of the manual

Regarding the salt log:
If you don’t have the /usr/sbin/upload-salt-reports file, something may have failed during installation. It should contain this file.

1 Like