ERF12-5356 Problem with puppetserver 5.3.5?

Attempted to delete a host, encountered puppetca related proxy error. Proceeded to look at smart-proxy (by webui), and also am unable to view puppet certs, UI shows the same error.

Expected outcome:
Puppetca access is available

Foreman and Proxy versions:

Foreman and Proxy plugin versions:

Other relevant data:
Puppet Server version 5.3.5.

/etc/foreman-proxy/settings.d/puppetca.yml is dated Aug 2018, which is the last time I upgraded Foreman. I have one system to provision, from this platform which has been running stable since the last upgrade, last systems provisioned from this Foreman vm were completed in Sept '18. During the provision, dracut-initqueue times out - with out details but I now believe it’s related to the puppetca error. I had intended to wait to upgrade until 1.21 was available since I would like to go to puppet 6 on this VM. However after the provision fails, I decided to delete the new host and go forward with an upgrade. That’s when I found this error in depth, at this point I will still prep and upgrade, but I wanted to see if there is any guidance as to what causes this error in recent versions that are not using Puppet 6.


It would seem that 1.19 produced the same issue, but 1.20 seems to correct it. Not sure what’s changed exactly, the proxy’s puppetca.yml has little difference between these version upgrades. Wish I could identify what actually caused the issue.

Have you tried looking at the wiki page for this error? the linked pages include some possible trouble-shooting steps that may fix this error. If you did and still have this issue, any further information could be useful for debugging it - such as your puppetca.yml and proxy logs with debug logging enabled for the failing request.