Error: Failed to download metadata for repo: Cannot download repomd.xml: All mirrors were tried

Hello all,
I’ve correctly set up a sync plan,epel,content view,activation key and registered foreman to use itself for repos.
After doing all the above, i did a reboot and fired up a dnf update and got this errors:

Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)                                                                                        0.0  B/s |   0  B     00:00    
Errors during downloading metadata for repository 'rhel-8-for-x86_64-appstream-rpms':
  - Curl error (56): Failure when receiving data from the peer for https://myforeman/pulp/content/ORG/Library/RHEL8_CV/content/dist/rhel8/8/x86_64/appstream/os/repodata/repomd.xml [Received HTTP code 503 from proxy after CONNECT]
Error: Failed to download metadata for repo 'rhel-8-for-x86_64-appstream-rpms': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

Expected outcome:
Access to repos
Foreman and Proxy versions:
Foreman 3.5.1 with Pulpcore, Logs, Puppet CA, Puppet, Openscap, Dynflow, and Script
Foreman and Proxy plugin versions:
foreman-tasks 7.1.1
foreman-openscap 5.2.2
foreman_puppet 5.0.0
foreman_remote_executions 8.2.0
katello 4.7.2
Distribution and version:
RHEL 8.7
Other relevant data:

name = Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)
baseurl = https://myforeman/pulp/content/ORG/Library/RHEL8_CV/content/dist/rhel8/$releasever/x86_64/appstream/os
enabled = 1
gpgcheck = 1
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
sslverify = 1
sslcacert = /etc/rhsm/ca/katello-server-ca.pem
sslclientkey = /etc/pki/entitlement/54249169116756568-key.pem
sslclientcert = /etc/pki/entitlement/54249169116756568.pem
metadata_expire = 86400
enabled_metadata = 1

subscription-manager identity 
system identity: 8ef18cf9-b972-4f0e-8976-3a4ea81bbe27
name: myforeman
org name: ORG
org ID: ORG
environment name: Library/RHEL8_CV

rpm -qa | grep katello-ca-consumer

Even by tweaking sslverify = 1 to sslverify = 0 i get the same errors, by following this certificate pointing my browser to the base url i can navigate repos

Hi Vesco, Did you ever get this resolved as I am having the same issue.