Error on install -- appears to be smartproxy <?>

I tried foreman a long long long time ago and it was very complicated to
function correctly. Checking out the new version - all I can say is WOW
this has come a long way! My hat is off to the team!

This is my first go with the newer version. I already had puppet w/
passenger up and running. Everything was stable, so I decided to change
something :wink:

I received this error on install:
Could not set 'present' on ensure: 422 Unprocessable Entity at
12:/usr/share/foreman-installer/modules/foreman_proxy/manifests/register.pp
Could not set 'present' on ensure: 422 Unprocessable Entity at
12:/usr/share/foreman-installer/modules/foreman_proxy/manifests/register.pp
/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[<nodename>]/ensure:
change from absent to present failed: Could not set 'present' on ensure:
422 Unprocessable Entity at
12:/usr/share/foreman-installer/modules/foreman_proxy/manifests/register.pp

when a node runs now, I get the following error:
Apr 16 22:34:11 <hostname> puppet-agent[24580]: Could not retrieve catalog
from remote server: Error 400 on SERVER: Failed when searching for node
<nodename>: Failed to find <nodename> via exec: Execution of
'/etc/puppet/node.rb <nodename>' returned 1:

I found another thread that described this as the smartproxy and that I
should register it within the foreman UI. However this failed also… Not
sure what to do next to get this AWESOME software up and running…

Any help is GREATLY appreciated!!

Thank you,
Austin

A few more details here… It appears an nmap of the localhost vs. public IP
shows ports open on localhost that are not open on the public IP. Although
the foreman-installer reports the foreman-proxy is running on the
hostname:8443, it actually IS NOT, and is only running on localhost.

Please note, I temporarily turned off my firewalld service during an
install and throughout the troubleshooting process here.

can anyone advise where I may adjust my bindings for this service or should
I redirect to localhost in foreman settings??

Thanks!

··· On Friday, April 17, 2015 at 12:37:49 AM UTC-4, Austin Smith wrote: > > I tried foreman a long long long time ago and it was very complicated to > function correctly. Checking out the new version - all I can say is WOW > this has come a long way! My hat is off to the team! > > This is my first go with the newer version. I already had puppet w/ > passenger up and running. Everything was stable, so I decided to change > something ;) > > I received this error on install: > Could not set 'present' on ensure: 422 Unprocessable Entity at > 12:/usr/share/foreman-installer/modules/foreman_proxy/manifests/register.pp > Could not set 'present' on ensure: 422 Unprocessable Entity at > 12:/usr/share/foreman-installer/modules/foreman_proxy/manifests/register.pp > /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[**]/ensure: > change from absent to present failed: Could not set 'present' on ensure: > 422 Unprocessable Entity at > 12:/usr/share/foreman-installer/modules/foreman_proxy/manifests/register.pp > > > when a node runs now, I get the following error: > Apr 16 22:34:11 puppet-agent[24580]: Could not retrieve catalog > from remote server: Error 400 on SERVER: Failed when searching for node > **: Failed to find ** via exec: Execution of > '/etc/puppet/node.rb **' returned 1: > > > I found another thread that described this as the smartproxy and that I > should register it within the foreman UI. However this failed also.. Not > sure what to do next to get this AWESOME software up and running........... > > Any help is GREATLY appreciated!! > > Thank you, > Austin >

> can anyone advise where I may adjust my bindings for this service or should
> I redirect to localhost in foreman settings??

It should run by default on all interfaces. It's in

/etc/foreman-proxy/foreman-proxy.yaml

LZ

··· -- Later, Lukas #lzap Zapletal

Only in 1.8 or above.

It's likely if you're on 1.7 that you have a newer "rack" gem installed.
See
https://groups.google.com/forum/#!msg/foreman-users/5fhXp7e_u5Q/EFwNixxI4KsJ
for more details.

··· On 18/04/15 20:22, Lukas Zapletal wrote: >> can anyone advise where I may adjust my bindings for this service or should >> I redirect to localhost in foreman settings?? > > It should run by default on all interfaces. It's in > > /etc/foreman-proxy/foreman-proxy.yaml


Dominic Cleal
Red Hat Engineering

that file does not exist on my machine. All I have in that directory is
settings.d directory and settings.yaml.

Can you please advise the format and directives?

thank you-

··· On Saturday, April 18, 2015 at 3:22:30 PM UTC-4, Lukas Zapletal wrote: > > > can anyone advise where I may adjust my bindings for this service or > should > > I redirect to localhost in foreman settings?? > > It should run by default on all interfaces. It's in > > /etc/foreman-proxy/foreman-proxy.yaml > > LZ > > -- > Later, > Lukas #lzap Zapletal >

Thank you for the help, Gents!!

Another confirmation the duplicate Rack gems was the culprit. I
uninstalled the latest and it works great!

Thank you!! On to the next hurdle! :wink:

··· On Monday, April 20, 2015 at 7:28:51 PM UTC-4, Austin Smith wrote: > > that file does not exist on my machine. All I have in that directory is > settings.d directory and settings.yaml. > > Can you please advise the format and directives? > > thank you- > > On Saturday, April 18, 2015 at 3:22:30 PM UTC-4, Lukas Zapletal wrote: >> >> > can anyone advise where I may adjust my bindings for this service or >> should >> > I redirect to localhost in foreman settings?? >> >> It should run by default on all interfaces. It's in >> >> /etc/foreman-proxy/foreman-proxy.yaml >> >> LZ >> >> -- >> Later, >> Lukas #lzap Zapletal >> >