Error Run scan for all OpenSCAP policies on host

Problem: Run scan for all OpenSCAP policies on host not working

Expected outcome: Solved

Foreman and Proxy versions: 1.23

Foreman and Proxy plugin versions: 1.23

Distribution and version: 1.23/Katello

I want to run remote scan for openscap policies on host but its not working. It’s looks ssl problem, i cannot solved this problem. Please help me.

Hi, it does not seem as ssl issue. Rather the url https://centostest.lcwaikiki.local:9090 returns 404, is proxy up and running there? Can it be resolved properly? By the .local suffix, I guess it’s running on localhost? Check that proxy logs at /var/log/foreman-proxy/, perhaps there’s more info.

Here is the proxy.log file. Can you check it ?
Best regards.

proxy.log (74.8 KB)

Ok, from the log it looks like the 404 was returned for some custom access on url /usr. Other errors that I see are related to SSL, they return 403. The log says no client certificate was used. How did you configure foreman_scap_client? See /etc/foreman_scap_client/config.yaml, namely following keys:

1 Like