External foreman-proxy installation


Having a foreman-server/foreman-proxy in one server I’m trying to install foreman-proxy in a separated freshly installed server following the doc in Foreman :: Manual (section 3.2.3):

foreman-installer \
  --no-enable-foreman \
  --no-enable-foreman-puppet \
  --no-enable-foreman-cli \
  --no-enable-foreman-cli-puppet \
  --no-enable-puppet \
  --enable-foreman-proxy \
  --foreman-proxy-foreman-base-url=https://foreman-server.com \
  --foreman-proxy-trusted-hosts=foreman-server.com \
  --foreman-proxy-oauth-consumer-key=<key here> \
  --foreman-proxy-oauth-consumer-secret=<secret here>

One of the problems is foreman-installer doesn’t recognized the following option:

ERROR: Unrecognised option '--no-enable-foreman-puppet'

Executing the installer without that option it raised the following errors:

2022-01-24 12:18:20 [ERROR ] [configure] Evaluation Error: Error while evaluating a Resource Statement, Foreman::Plugin[puppet]:                                                                                                               
2022-01-24 12:18:20 [ERROR ] [configure] parameter 'version' expects a String value, got Undef
2022-01-24 12:18:20 [ERROR ] [configure] parameter 'config_file_group' expects a String value, got Undef (file: /usr/share/foreman-installer/modules/foreman/manifests/plugin/puppet.pp, line: 6) on node foreman-proxy.com

Expected outcome:

foreman-installer installs foreman-proxy without any error.

Foreman and Proxy versions:

foreman-proxy 3.1.0
foreman-installer 3.1.0

Foreman and Proxy plugin versions:

Distribution and version:

Rocky Linux 8.5

Other relevant data:

I’m having the same error on Debian 10 trying to install Smart Proxy Server.
Followed documentation

  foreman-installer \
  --no-enable-foreman \
  --no-enable-foreman-cli \
  --enable-puppet \
  --puppet-server-ca=false \
  --puppet-server-foreman-url=https://foreman.local.lan \
  --enable-foreman-proxy \
  --foreman-proxy-puppetca=false \
  --foreman-proxy-tftp=false \
  --foreman-proxy-foreman-base-url=https://foreman.local.lan \
  --foreman-proxy-trusted-hosts=foreman.local.lan \
  --foreman-proxy-oauth-consumer-key=xxxxxxxxxxxxxxxxxxxx \

thank you for your answer .

Problem is .

With those setting proxy complaibs about ssl cert not signed .

Plus can this proxy surve as ca “proxy” for the main ca on master fireman server or do i need on each proxy ca to sign it puppet clients ???