Failed to fetch kickstart again

timeouts and dns
Expected outcome:

Foreman and Proxy versions:

I all, we’ve recently been getting the above error when trying to build a machine in one of our DC’s, but all others (4 DC’s) are fine
The error shows a timeout when connecting to our server which has the OS on it. It attempts 3 of 4 times and keeps saying blem: timeout Will retry in 1 seconds, 3 retries left. Then an occasional message saying could not resolve host: (our foreman master)

It can definitely resolve as the IP is in local hosts on that machine as well as AD DNS that it has and Ive tested successfully.
I’ve also tried connecting to the server that contains the OS we are trying to get and can connect on 443, fine

Any ideas please?
Again this only fails on 1 DC, the others are fine. Same templates are linked to the main OS.

I would say there is a network problem. Problems I had in the past in similar environments were a different MTU was required, someone only allowed udp and forgot about tcp for DNS, some kind of asynchron routing which resulted in network packages not finding their way back, another DHCP server with different configuration resulting the host not getting DNS server.

Not sure if any of this could be the reason here or if you already sorted out some of those, but I would start with network debugging in your case.

thanks, I have just tried building in the same problematic DC but with another network there and worked fine!
Seems to be just this one network that we recently had to change under subnets (and also mirrored the change under dhcpd and restarted).

On a related side note - does anyone know where foreman gets the list from under the interface > VMWare section > network?
Its a field that cant be edited once saved unfortunately. But it needs clearing up on our Foreman setup. I suspect it could be linked to the issue

nevermind - it seems to be directly from vmware. Just checked ours and matches

This is resolved. It was still linking to the old network in that interface drop down list. Pointed it to the new after setting the DHCP relay in our FW and all good again

1 Like