Failed to use discovery over tagged vlan(trunk port) uefi pxe

Hi ,

I have tried configuring the discovery plugin using the documentation but have encountered an issue and would like your help .
My network setup consists of a bare metal server connected to trunk port using vlan tagging to connect to the network I am trying to do PXE boot with UEFI a little after the pxe boot starts , I see the following message: fetching netboot image
in this stage it hangs forever , I am unsure which provisioning template I should use for UEFI and I saw
some examples online which didn’t work.
I tried the following templates : pxegrub2_discovery , pxegrub2_discovery , PXELinux global default ,
I am unsure which parameters exactly to use and if the URL needs to contain 8443 port for example ,

my final goal after a successful discovery to my nodes is to clone one server os (Rocky 8.5 ) to another discovered server .

Foreman version 3.2.0 , foreman_discovery 20.0.1

your help will be appreciated :slightly_smiling_face: :pray:

My guess is that there is something wrong with the TFTP server. Do you have logs or a packet capture? Netboot, and especially UEFI, can behave strangely depending on hardware. I would also suggest making sure that your hosts have the latest firmware.

VLAN tagging is not well tested in Grub2 and there are probably some bugs. If you are able to isolate the mishehavior open Bugzillas to Red Hat.

Thanks for your reply , to try and troubleshoot this issue I set the switch port to access mode instead of trunk , after this I discovery still didn’t work but when running the discovery image manually from host the discovery worked ,
what could be the issue ?
how can I provision the host with os rocky linux or clone another host to it ?
The documentation on your site is a bit general in my opinion and lacks screen shots and tutorials.
please advise.

Hi ,

another question , I was able to discover a host manually booting to the FDI image from the management console, I get the below error when I try to deploy rocky 8.5 image ,
please tell me how I can disable the discovery process and deploy regual OS ,
which templates I need to use ?


Docs about HTTP UEFI boot should help I guess.

Done all the steps in the doc but I still get the above massage saying “Default PXE global template is set to discovery” , how do I disable this discovery process and switch to provision rocky linux 8.5?

That message is just informative, you have to dig deeper. I see HTTP Boot in use, so check your network, firewalls – in HTTP Boot the host is fetching the grub configuration over HTTP. Also HTTP Boot support in grub2 is bugged quite a bit, make sure to use grub2 (on the smart proxy) from at least RHEL 8.5+ or Fedora.