Few questions regarding Foreman

I am fairly new to Foreman and puppet and this community. I will introduce myself later on in the introduction section.

Now i have a school project where i have to use foreman and puppet for provisioning on bare metal and virtualisation platform.

I use Vmware vsphere 6.5 and vcenter for the virtualisation platform.

I have installed a Ubuntu 18,04 host with foreman. Puppet is also running on this machine.
I have a MS2016 Domain Controller that has DHCP, DNS and AD.

Foreman is connected to the vmware platform.
Now the fun part starts:

When i deploy/provisioning a VM on vmware with foreman. He creates a VM and i see the vm is created but he keeps saying that he does not receive a bootfile.

I have tried now a few days to fix this challange and it raises a few questions.

  1. Do i need iso’s from ubuntu or centos to provision or can i use the installation media?
  2. Do i need to create a dhcp smart proxy’s for DHCP to receive a ip from the scope?
  3. Why does it keep saying that he did not receive a bootfile?

The logfile i will upload very soon. It is the production.log right ?(production is also the name of our puppet environment).

With kind regards,


production.log (1.5 MB)
i could not upload it in the post above. it said i was not allowed to see that section.

Versions of the software used.

Ubuntu 18.04
Foreman version: 1.20
Microsoft Server: 2016 (not sure if it is needed)
Vmware Vsphere 6.5

IP Addresses used:

Not so good at MS dhcp and dns integration but what I feel here is, until and unless Foreman knows what ip dhcp will be giving to virtual system it would be difficult to have pxelinux entry. Are you having external smart proxy on windows system ? which is having dhcp, dns enabled something like below,


Apart from this if that external dhcp, dns can not be managed by Foreman then I think you can do PXELess Discovery, here kexec should help you to kickstart system. Maybe someone else who has better understanding of MS dhcp, dns integration can give more pointers.

I have tried to create a smart proxy for windows server 2016 DHCP & DNS.
The point is about this, that i can not get it to work because some ruby gems could not been installed and because of that i could not get the windows service to start. So

Maybe Windows Server 2016 is not supported yet? should i try the ubuntu isc dhcp ? and create a smart proxy with that?

Furthermore i have never worked with kexec. but i am willing to give it a try, do you have any guidelines on how to start using this?

There’s bunch of errors in the log file you’ve provided. I see oVirt compute resource errors but you are saying it’s VMWare, just paste the error message you want to know more about. Also try googling it first.

Need exact error message for this one.

Seriously, read our documentation it’s not long. There are couple of diagrams explaining how provisioning work.