Foreman 1.0.1 "already initialized constant" cron spam

The issue here lies not in the Foreman codebase itself, but rather in the
ruby_parser gem. The author appears to be working toward a new major
version so the fix has yet to be released. See
https://github.com/seattlerb/ruby_parser/issues/18.

-Sam

··· On Fri, Aug 31, 2012 at 7:47 AM, Daniel Piddock wrote:

Hi all,

I’ve recently upgraded from 0.4.2 to 1.0.1 on Debian Squeeze. Packages
installed from the deb.theforeman.org archive.

Whenever a foreman task is run the following lines are spat out to stderr:

Libvirt binding are missing - hypervisor management is disabled
/usr/share/foreman/vendor/ruby/1.8/gems/ruby_parser-2.3.1/lib/ruby_parser_extras.rb:10:
warning: already initialized constant ENC_NONE
/usr/share/foreman/vendor/ruby/1.8/gems/ruby_parser-2.3.1/lib/ruby_parser_extras.rb:11:
warning: already initialized constant ENC_EUC
/usr/share/foreman/vendor/ruby/1.8/gems/ruby_parser-2.3.1/lib/ruby_parser_extras.rb:12:
warning: already initialized constant ENC_SJIS
/usr/share/foreman/vendor/ruby/1.8/gems/ruby_parser-2.3.1/lib/ruby_parser_extras.rb:13:
warning: already initialized constant ENC_UTF8

This isn’t a huge problem it’s just mildly annoying. Is there any way to
stop this spam or is it indicative of a wider problem? It happens on both
my live environment and a test install.

OS ruby packages:
libactionmailer-ruby1.8 2.3.5-1.2+squeeze3
libactionpack-ruby1.8 2.3.5-1.2+squeeze3
libactiverecord-ruby1.8 2.3.5-1.2+squeeze3
libactiveresource-ruby1.8 2.3.5-1.2+squeeze3
libactivesupport-ruby1.8 2.3.5-1.2+squeeze3
libaugeas-ruby1.8 0.3.0-1.1
libbreakpoint-ruby1.8 0.5.1-2
libbuilder-ruby1.8 2.1.2-2
libcmdparse2-ruby1.8 2.0.2-2
libdaemons-ruby1.8 1.0.10-2
libdbd-pg-ruby 0.3.9-1
libdbd-pg-ruby1.8 0.3.9-1
libdbi-ruby1.8 0.4.3-2
libdeprecated-ruby1.8 2.0.1-2
libi18n-ruby1.8 0.4.1-1
liblog4r-ruby1.8 1.0.5-8
libmemcache-client-ruby1.8 1.7.8-2
libmmap-ruby1.8 0.2.6-3
libmocha-ruby1.8 0.11.3-2
libncurses-ruby1.8 1.2.4-2
libpgsql-ruby1.8 0.13.2-2
librack-ruby 1.1.0-4
librack-ruby1.8 1.1.0-4
libredcloth-ruby1.8 4.2.2-1.1
libruby 4.5
libruby1.8 1.8.7.302-2squeeze1
libruby1.8-extras 0.5
libshadow-ruby1.8 1.4.1-8
libsqlite3-ruby1.8 1.2.4-2.1
libtext-format-ruby1.8 1.0.0-2
libtmail-ruby1.8 1.2.3.1-1
libtzinfo-ruby1.8 0.3.19-1
rails 2.3.5-1.2+squeeze3
rails-ruby1.8 2.3.5-1.2+squeeze3
rake 0.9.2.2-4
ruby 4.5
ruby-bundler 1.1.3-2
ruby-metaclass 0.0.1-2
ruby-mocha 0.11.3-2
ruby-pg 0.13.2-2
ruby1.8 1.8.7.302-2squeeze1
ruby1.8-dev 1.8.7.302-2squeeze1
rubygems 1.8.24-1
rubygems1.8 1.8.24-1

foreman bundle gems:
abstract-1.0.0
actionmailer-3.0.15
actionpack-3.0.15
activemodel-3.0.15
activerecord-3.0.15
activeresource-3.0.15
activesupport-3.0.15
ancestry-1.2.5
arel-2.0.10
audited-3.0.0.rc1
audited-activerecord-3.0.0.rc1
builder-2.1.2
erubis-2.6.6
i18n-0.5.0
jquery-rails-1.0.19
json-1.7.5
mail-2.2.19
mime-types-1.19
net-ldap-0.3.1
polyglot-0.3.3
rack-1.2.5
rack-mount-0.6.14
rack-test-0.5.7
rails-3.0.15
railties-3.0.15
rake-0.9.2.2
rdoc-3.12
rest-client-1.6.7
ruby2ruby-1.3.1
ruby_parser-2.3.1
safemode-1.0.1
scoped_search-2.3.7
sexp_processor-3.2.0
thor-0.14.6
treetop-1.4.10
tzinfo-0.3.33
uuidtools-2.1.3
will_paginate-3.0.3

Thank you,
Dan


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To view this discussion on the web visit
https://groups.google.com/d/msg/foreman-users/-/rzA8dX9kq2sJ.
To post to this group, send email to foreman-users@googlegroups.com.
To unsubscribe from this group, send email to
foreman-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/foreman-users?hl=en.