Foreman 1.23-develop Blank White Screen after Login


#1

Problem: Instead of getting the main dashboard view, I get a blank screen.

Expected outcome: Default dashboard view should have been seen after login

Foreman and Proxy versions:

RPMs:

foreman-debug-1.23.0-0.5.develop.20190509222947git988d135.el7.noarch
foreman-1.23.0-0.5.develop.20190509222947git988d135.el7.noarch
foreman-selinux-1.23.0-0.1.develop.20190509083208git0c2d1f0.el7.noarch
foreman-mysql2-1.23.0-0.5.develop.20190509222947git988d135.el7.noarch

Foreman and Proxy plugin versions:

Foreman: 1.23-develop
Smart-Proxy: not used (installed via Puppet Forge modules - theforeman/puppet and theforeman/foreman)

Other relevant data:
[e.g. logs from Foreman and/or the Proxy, modified templates, commands issued, etc]
(for logs, surround with three back-ticks to get proper formatting, e.g.)

logs

I had a prior install working with CentOS 7, Puppet 6 and Foreman 1.23-develop using the following servers:

  • Puppet CA
  • Puppet Catalog
  • PuppetDB DB Server (Postgresql)
  • PuppetDB App Server
  • Foreman DB Server (MariaDB)
  • Foreman App Server

I have redeployed these servers trying to get a redundant PuppetCA setup (set that aside for now) and have redundant Puppet Catalog server up behind a load balancer. I was able to deploy the PuppetDB and Foreman db/application servers using the load balancer in front of the Puppet Catalog servers.

My prior working solution was also on CentOS 7 and Puppet 6.x … I don’t know what specific RPM updates may have come out in the last week that could have an impact.

When I reload the page in the web browser (using both Chrome and Firefox – on a Mac OS X system), I get the following entries in /var/log/foreman/production.log:

==> production.log <==
2019-05-15T21:19:06 [I|app|544e4c25] Started GET “/” for 172.28.0.74 at 2019-05-15 21:19:06 +0000
2019-05-15T21:19:06 [I|app|544e4c25] Processing by DashboardController#index as HTML
2019-05-15T21:19:06 [I|app|544e4c25] Current user set to admin (admin)
2019-05-15T21:19:06 [I|app|544e4c25] Rendering dashboard/index.html.erb within layouts/application
2019-05-15T21:19:06 [I|app|544e4c25] Rendered dashboard/index.html.erb within layouts/application (40.5ms)
2019-05-15T21:19:06 [I|app|544e4c25] Rendered common/_searchbar.html.erb (0.3ms)
2019-05-15T21:19:06 [I|app|544e4c25] Rendered layouts/_application_content.html.erb (0.9ms)
2019-05-15T21:19:06 [I|app|544e4c25] Rendering layouts/base.html.erb
2019-05-15T21:19:06 [I|app|544e4c25] Rendered layouts/base.html.erb (15.9ms)
2019-05-15T21:19:06 [I|app|544e4c25] Completed 200 OK in 68ms (Views: 57.4ms | ActiveRecord: 2.4ms)

I do not appear to be having issues with SElinux. I get the same results after ‘setenforce 0’ or after ‘setenforce 1’


#2

Hi, could you take a look at the browser console (usually Ctrl+Shift+I, console tab)?


#3

Nightly is currently broken due, AFAIK due to a patternfly update that hasn’t been packaged. Working on it.


#4

Ok, will wait for an update in the nightly build


#5

Is it still broken? Or is my local mirror of yum.theforeman.org not current? I just tried rebuilding my Foreman application server and still got a blank white page after the login screen.

Thanks,
David


#6

if you had foreman tasks installed, it is likely you hit
https://github.com/theforeman/foreman/pull/6770/, which was merged earlier
today, so hopefully next nightly will be better :slight_smile:

thanks for testing our nighties… :slight_smile:


#7

nightlies have actually been broken for over a week now due to Bug #26830: Redux-form 8 is incompatible with react-redux 5 - Foreman which will hopefully be fixed soon.


#8

Foreman nightlies should now be working. There is a known issue is katello nightlies that is being worked on.