Foreman 1.24, Katello 3.14 Unable to perform package actions

I’m not a developer but wanted to report an issue.
After the update to 1.24 RC3 we are not able to install or remove packages over the content host view.

We are getting an error message: The resource Host::Managed doesn’t define any available lock

We also tested this behavior with a fresh install. No error message found the foreman logs. No idea where to search now.

Expected outcome:

Packages should be installed, updated or removed

Foreman and Proxy versions:

Foreman 1.24 RC3
Katello 3.12

Foreman and Proxy plugin versions:

Chef Plugins installed. Puppet disabled

Distribution and version:
CentOS 7.7

Other relevant data:
No relevant log entrys found yet

Hello @freduardo, can you find and share here a stack trace in /var/log/foreman/production.log relating to the error you mentioned?

1 Like

Hi @Jonathon_Turel ,
i attached the trace from the log. production.log (48.0 KB)

Hope this helps.

1 Like

@aruzicka any ideas on the stack trace in the above log file? I’m not sure what would cause it.

Nope, doesn’t ring a bell. I tried looking along the stack trace and nothing in there really changed in ages.

::Host::Managed should have an .available_locks class method availabe, but apparently it doesn’t. Which doesn’t seem right, as multiple modules providing it should be included into that class :thinking:

I think that may be part of the issue - Katello 3.12 is compatible with foreman 1.22, you would need to upgrade katello to 3.14 for it to match foreman. Also please make sure you update all other plugins to the versions available in the 1.24 repo.

Sorry I misstyped that! The versions in the post-summary are correct.

We did a update and a separate fresh install via the Katello 3.14 manual. All Packages are up to date with the Katello 3.14 Repos and the Foreman 1.24 Repos. Couldn’t edit the original Post

1 Like

Does anyone else have this issue? Is it repoducable?
I haven’t tested a “clean” installation without chef and puppet enabled, but should make no difference?
Same installation procedure worked with 1.22/1.23

It’s very odd. Can you provide the output of rpm -qa | grep 'foreman-tasks\|dynflow' on your Foreman box?


Do you think this can be fixed for the 1.24 release?

@freduardo are you also seeing this issue on the fresh 1.24RC + Katello 3.14RC + Chef plugin + no puppet installation?

If so, please tell me about how you installed so that I can try to reproduce.

1 Like

@Jonathon_Turel this means the issue does not occur on a “normal” Katello installation with standard settings?

As I am out of office today, I will provide the full installer commands tomorrow. Thanks in advance! :slight_smile:

@freduardo that’s right - it seems to work fine on my fresh install of the version you mentioned earlier. In fact, this scenario is part of our regular testing, so that’s why I’m curious about your specific installation.

@Jonathon_Turel these Commands were used for the installation:

groupadd puppet (needed because the installer does not add “puppet” when puppet is disabled, but requires that the group exists)

foreman-installer --scenario katello --enable-foreman-plugin-chef --enable-foreman-plugin-tasks --enable-foreman-proxy-plugin-chef --foreman-proxy-plugin-chef-server-url="https://ChefServer/organizations/Org" --foreman-proxy-plugin-chef-client-name="FQDN of Foreman Server" --foreman-proxy-plugin-chef-private-key="/path/to/client.pem" --no-enable-puppet --foreman-server-ssl-crl="" --foreman-initial-organization "org" --foreman-initial-location "location"

foreman-installer --scenario katello --certs-server-cert "/etc/pki/tls/certs/ssl.crt" --certs-server-key /etc/pki/tls/private/ssl.key" --certs-server-ca-cert "/etc/pki/tls/certs/CA.crt" --certs-update-server --certs-update-server-ca