Foreman 1.24 RC3-Could not set groups on user [foreman]


I want to run the foreman-installer command in a connected environment, but there is a error message.

Could not set groups on user [foreman] : Execution of ‘/usr/sbin/usermod -G puppet foreman’ returned 6: usermod: group ‘puppet’ does not exist.

I had disable puppet-server and enable foreman-proxy.

I already install it, it was success, I had some problem, but never this one.

I also can’t use the puppet command to generate the certificate. I have puppet-agent-6.11.1-1 and puppet-agent-oauth-0.5.1-3

Foreman and Proxy versions:

How are you trying to install? Ideally the installer command that you run.

I already instaled Foreman in one VM. But to confirm all step, I would like to reinstall it again in an other VM.

I think this is not a specific 1.24 bug.
I am getting this error every time when i do a clean install, because I disable puppet in the installation.

It seems that the group “puppet” is required even if puppet installation is disabled.

Workaround: create a group “puppet” before you install foreman. Even if it is not needed

Ok thank you fr your information. Then the command is groupeadd puppet.

Correct. This has been a long standing bug and I’m not entirely sure how to cleanly fix it. This is done so Foreman can read certificates from the Puppet CA. When you disable Puppet and provide your own certificates you can pass in --foreman-user-groups EMPTY_ARRAY but this isn’t obvious.