Foreman 3.1 to 3.2 upgrade had module anomaly

After upgrading a Smart Proxy, the latest Foreman and Katello rpms were not installed or available, although they were in the parent Foreman. RC versions were installed. All seemed to go well during the upgrade and foreman-installer run but foreman and katello modules were not enabled.
Expected outcome:
The latest versions would be installed.
Foreman and Proxy versions:
Foreman 3.1.3 > 3.2.1
Katello 4.3.x > 4.4.0
Foreman and Proxy plugin versions:

Distribution and version:
RHEL 8.6
Other relevant data:
I was able to mitigate this by using dnf module reset and enable for foreman and katello. Module pulpcore was enabled correctly. This is informational for you folks.

1 Like

For installation it is documented to enable the modules after installing the release package and before the installer package, what makes sense.

In the upgrade documentation I do not see it is mentioned, so the installer (or some other automatism) would have to do it, but this is to late I think, so the documentation needs to include this step.
(Not sure if this needs some discussion how it should work or simply an addition to the docs, so pinging @mcorr)

1 Like

I should add that upgrading the main Foreman instance worked as anticipated. It was only the smart proxy that had an issue.

Interesting, I tried this on centos8-stream and I couldn’t reproduce the issue. I upgraded my smart proxy from 4.3 to 4.4 without touching any modules. Perhaps the modules were somehow optional on 4.3, and your installation didn’t have them, but mine did? Unless something was fixed :slight_smile: