Foreman 3.10 RC1 Katello EL9 install Rockey Linux 9.3

I tried to install Foreman 3.10 RC1 with Katello latest on Rockey Linux 9.3 below is what I did disabled firewall. I am trying to do a quick and dirty install don’t plan to keep the install long term just wnat to look at it and play around.

dnf -y install
dnf -y install
dnf -y install
dnf clean all
nf -y module enable foreman-devel:el9
dnf -y install foreman-installer

  ' | RUBYLIB=/usr/share/gems/gems/kafo-7.4.0/lib/kafo/../..//modules: /opt/puppetlabs/bin/puppet apply --config=/tmp/kafo_installat                             ion20240302-5094-s9er7t/puppet.conf

2024-03-02 06:04:59 [ERROR ] [root] Error: The parameter ‘$slowlog_log_slower_than’ must be a literal type, not a Puppet::Pops::Model::A ccessExpression (file: /usr/share/foreman-installer/modules/redis/manifests/init.pp, line: 432, column: 15) on node

2024-03-02 06:04:59 [ERROR ] [root] Could not get default values, cannot continue

What did I miss?

I also tried puppet8-release-el-9.noarch.rpm and puppet7-release-el-9.noarch.rpm.

Thanks I for the reply I just saw what also.

I am facing same issue with new fresh install even if you change the value to zero it will come up with the error for kafo which I am not sure what to change after that. I am running on Alma 8 with foreman
[root@foreman ~]# sudo foreman-installer
2024-03-02 21:27:59 [NOTICE] [root] Loading installer configuration. This will take some time.
2024-03-02 21:28:05 [NOTICE] [root] Running installer with log based terminal output at level NOTICE.
2024-03-02 21:28:05 [NOTICE] [root] Use -l to set the terminal output log level to ERROR, WARN, NOTICE, INFO, or DEBUG. See --full-help for definitions.
2024-03-02 21:29:12 [NOTICE] [configure] Starting system configuration.
2024-03-02 21:29:17 [ERROR ] [configure] The parameter ‘$request_timeout’ must be a literal type, not a Puppet::Pops::Model::AccessExpression (file: /usr/share/foreman-installer/modules/foreman/manifests/cli.pp, line: 36, column: 15) on node
2024-03-02 21:29:17 [NOTICE] [configure] System configuration has finished.

There were errors detected during install.
Please address the errors and re-run the installer to ensure the system is properly configured.
Failing to do so is likely to result in broken functionality.

The full log is at /var/log/foreman-installer/foreman.log

sudo dnf -y install

Enable the Foreman repositories:

sudo dnf -y install

Enable the Foreman module:

sudo dnf -y module enable foreman:el8

Downloading the installer

sudo dnf -y install foreman-installer

[root@localhost ~]# foreman-installer
/usr/share/gems/gems/kafo-7.4.0/lib/kafo/puppet_module.rb:70:in parse': No Puppet module parser is installed and no cache of the file /usr/share/foreman-installer/modules/foreman/manifests/cli.pp is available. Please check debug logs and install optional dependencies for the parser. (Kafo::ParserError) from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/configuration.rb:133:in block in modules’
from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/configuration.rb:133:in map' from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/configuration.rb:133:in modules’
from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/kafo_configure.rb:257:in modules' from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/kafo_configure.rb:261:in module’
from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/hook_context.rb:113:in module_present?' from /usr/share/foreman-installer/hooks/boot/20-certs_update.rb:2:in block (4 levels) in load’
from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/hooking.rb:36:in instance_eval' from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/hooking.rb:36:in block (4 levels) in load’
from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/hook_context.rb:19:in instance_eval' from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/hook_context.rb:19:in execute’
from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/hooking.rb:67:in block in execute' from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/hooking.rb:65:in each’
from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/hooking.rb:65:in execute' from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/kafo_configure.rb:144:in initialize’
from /usr/share/gems/gems/clamp-1.3.2/lib/clamp/command.rb:140:in new' from /usr/share/gems/gems/clamp-1.3.2/lib/clamp/command.rb:140:in run’
from /usr/share/gems/gems/kafo-7.4.0/lib/kafo/kafo_configure.rb:54:in run' from /usr/sbin/foreman-installer:8:in
[root@localhost ~]#

The only viable solution is to downgrade Puppet to 7.28.0 for now.