Foreman 3.2 Remote execution issue

**Problem: In our environment we have several locations and each location has its smart proxy. When running ssh or ansible job on hosts from different locations the task is successful only on the first host, others fail with connection timed out. I found that it is caused because the foreman tries to run the task through only one capsule that is assigned to the first host. This can be mitigated by setting the Concurrency level to some value or by setting the Allow proxy batch tasks to No in Settings->Tasks **

Is it a bug or expected behaviour ? It worked fine in foreman 2.5 which we then upgraded to 3.2

Foreman and Proxy versions: 3.2 and 3.2

Foreman and Proxy plugin versions: 3.2

Distribution and version: RHEL 7

Other relevant data:

That could be possibly fixed by this Fixes #34447 - Fix batch triggering with multiple proxies, vol. 2 · theforeman/foreman-tasks@63c4f5f · GitHub . If that is it, then it should land in foreman-tasks-6.0.1. It is not in the repos yet, but it is being worked on.

Ok, thank you for your information.