Foreman + Ansible Callback Plugin SSL Error

When I run my ansible playbook with Ansible AWX I get this error.

HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /api/v2/hosts/facts (Caused by SSLError(SSLError("bad handshake: Error([('SSL routines', 'ssl3_read_bytes', 'sslv3 alert unsupported certificate')],)",),))

Expected outcome:
That it should connect fine.

Foreman and Proxy versions:
Foreman and Proxy plugin versions:
foreman_ansible 2.3.3

Other relevant data:
AWX 4.0
Ansible 2.7.9


url = ''
ssl_cert = /etc/foreman-proxy/ssl_cert.pem
ssl_key = /etc/foreman-proxy/ssl_key.pem
verify_certs = /etc/foreman-proxy/ssl_ca.pem
1 Like

I am getting this also, was there a solution to this error/

I had the same issue after following these instructions but wasn’t using the correct cert/key, it worked when I changed the ssl_cert and ssl_key paths in my Ansible configuration to the same as those found in the auto-generated Apache configuration on Foreman (these are the proxy cert/key files) e.g.


Where {server} is your foreman server URL

Change the cert and key values to the following:

ssl_cert = /etc/foreman-proxy/foreman_ssl_cert.pem
ssl_key = /etc/foreman-proxy/foreman_ssl_key.pem
verify_certs = /etc/foreman-proxy/foreman_ssl_ca.pem

Sorry for necro-ing this thread, but it’s the first Google search result for this particular problem.